Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512883 - scala FTBFS in rawhide and f27
Summary: scala FTBFS in rawhide and f27
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scala
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1516916
TreeView+ depends on / blocked
 
Reported: 2017-11-14 11:55 UTC by Paulo Andrade
Modified: 2017-12-14 10:33 UTC (History)
5 users (show)

Fixed In Version: 2.10.6-6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-07 07:37:37 UTC


Attachments (Terms of Use)
scala-ftbfs-rawhide.patch (deleted)
2017-11-14 11:55 UTC, Paulo Andrade
no flags Details | Diff

Description Paulo Andrade 2017-11-14 11:55:59 UTC
Created attachment 1351910 [details]
scala-ftbfs-rawhide.patch

While attempting to correct the jacop FTBFS package, that
depends on scala, I believe I found a patch to rebuild scala.

$ dnf repoquery scala
scala-0:2.10.6-3.fc26.noarch
$ rpm -q scala
scala-2.10.6-5.fc28.noarch

  While it did not fix my issue, I believe I should share my
attempt fix, that appears to be correct, and is attached.

Comment 1 Kamil Dudka 2017-12-06 13:07:28 UTC
Not sure if it is directly related to this bug or not ... but I had to add BR for javapackages-local to be able to build scala-2.10.6-3.fc26 in the f27 build root because /usr/bin/abs2rel is no longer installed by javapackages-tools.

Comment 2 Mikolaj Izdebski 2017-12-06 13:15:16 UTC
It is related, but only one of several changes required to fix this FTBFS.

Comment 3 Kamil Dudka 2017-12-06 14:18:41 UTC
When can we expect an f27 build that can be rebuild in Fedora 27 build root?

Comment 5 Mikolaj Izdebski 2017-12-07 07:10:40 UTC
Fixed in scala-2.10.6-6

Comment 6 Mikolaj Izdebski 2017-12-07 07:37:37 UTC
It turned out that adding BR on javapackages-local was enough.

Built in rawhide, https://koji.fedoraproject.org/koji/buildinfo?buildID=1007876

f27 branch is buildable too (but not built), https://koji.fedoraproject.org/koji/taskinfo?taskID=23562032

Comment 7 Kamil Dudka 2017-12-07 08:05:38 UTC
Thanks!

When can we expect an f27 build that can be rebuild in Fedora 27 build root?

Comment 8 Mikolaj Izdebski 2017-12-07 08:09:08 UTC
I've just submitted f27 build to Koji: https://koji.fedoraproject.org/koji/taskinfo?taskID=23562542

Comment 9 Kamil Dudka 2017-12-07 08:16:50 UTC
I am able to rebuild scala-2.10.6-6.fc28 in the Fedora 27 build root, which is
sufficient for me.  Still it can save some time to others if builds tagged f27
are reproducible in up2date Fedora 27 buildroot.

Comment 10 Kamil Dudka 2017-12-07 08:17:09 UTC
(In reply to Mikolaj Izdebski from comment #8)
> I've just submitted f27 build to Koji:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=23562542

Thanks!

Comment 11 Kamil Dudka 2017-12-14 09:28:08 UTC
(In reply to Mikolaj Izdebski from comment #8)
> I've just submitted f27 build to Koji:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=23562542

Unfortunately, the above build failed because of an internal documenter error:

https://koji.fedoraproject.org/koji/getfile?taskID=23562561&volume=DEFAULT&name=build.log&offset=-4000

Comment 12 Mikolaj Izdebski 2017-12-14 10:33:25 UTC
Resubmitted on x86_64, https://koji.fedoraproject.org/koji/taskinfo?taskID=23679796


Note You need to log in before you can comment on or make changes to this bug.