Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512858 - The 'Next' button takes very long time to become enabled blue when ordering image
Summary: The 'Next' button takes very long time to become enabled blue when ordering i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.7.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 10:06 UTC by shahan
Modified: 2018-04-05 09:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On slow network connections, the Next button could sometimes take several secrets to enable when opening the create from builder image dialog on the OpenShift web console catalog landing page with the service catalog enabled. This problem has been fixed, and the Next button should now be enabled immediately when the dialog is displayed.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:32:08 UTC


Attachments (Terms of Use)
Console Output (deleted)
2017-11-14 10:06 UTC, shahan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:32:45 UTC

Description shahan 2017-11-14 10:06:38 UTC
Created attachment 1351852 [details]
Console Output

Description of problem:
    The 'Next' button takes very long time to become enabled blue when ordering image on the homepage. Used the F12 to inspect Console and found that  https://**:8443/apis/servicecatalog.k8s.io/v1beta1/clusterserviceplans takes almost 10s to finished 'Get' request. More detailed please see attachment.

Version-Release number of selected component (if applicable):
v3.7.7

How reproducible:
Always

Steps to Reproduce:
1. Login in web console and click Languages-> Python.
2.
3.

Actual results:
 Will take almost 10s to enable "Next" button to become blue

Expected results:
 Should change the button's status quickly 

Additional info:

Comment 1 Samuel Padgett 2017-11-14 13:06:42 UTC
This dialog should not be requesting service classes and service plans in 3.7.

Comment 2 Samuel Padgett 2017-11-14 13:19:23 UTC
Catalog PR:

https://github.com/openshift/origin-web-catalog/pull/568

Comment 3 Robb Hamilton 2017-11-28 17:38:25 UTC
PR to resolve: https://github.com/openshift/origin-web-console/pull/2493

Comment 4 Samuel Padgett 2017-11-29 13:11:12 UTC
Moving back to assigned as this fix still needs to be backported to 3.7.z

Comment 5 Samuel Padgett 2017-11-30 18:42:11 UTC
enterprise-3.7 catalog fix:

https://github.com/openshift/origin-web-catalog/pull/577

Comment 6 Samuel Padgett 2017-12-01 18:51:54 UTC
3.7.z console PR:

https://github.com/openshift/origin-web-console/pull/2551

Comment 8 Yadan Pei 2017-12-06 06:49:08 UTC
v3.7.13 doesn't include the changes yet, will check in next update

Comment 9 Yadan Pei 2017-12-08 02:49:19 UTC
Change to MODIFIED since fix not picked in OCP, and it couldn't be tested

Comment 14 shahan 2018-03-01 06:33:15 UTC
Checked in OpenShift Master v3.7.35, the bug has been fixed. 'Next' button works well now.

Comment 18 errata-xmlrpc 2018-04-05 09:32:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.