Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512851 - cyrus-imapd-3.0.4-2.fc28 FTBFS: imap/http_caldav.c:2034:8: error: 'struct icaltimetype' has no member named 'is_utc'
Summary: cyrus-imapd-3.0.4-2.fc28 FTBFS: imap/http_caldav.c:2034:8: error: 'struct ica...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:53 UTC by Petr Pisar
Modified: 2017-11-14 19:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 19:08:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1512849 None None None Never

Internal Links: 1512849

Description Petr Pisar 2017-11-14 09:53:44 UTC
cyrus-imapd-3.0.4-2.fc28 fails to build in F28:

gcc -DHAVE_CONFIG_H -I.   -I. -I./lib -I. -I./lib -DLIBEXEC_DIR=\"/usr/libexec/cyrus-imapd\" -DSBIN_DIR=\"/usr/sbin\" -DSYSCONF_DIR=\"/etc\" -DHAVE_CONFIG_H     -I/usr/include -I/usr/include/libxml2        -I/usr/include -fPIC  -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -c -o imap/http_caldav.o imap/http_caldav.c
make[2]: Leaving directory '/builddir/build/BUILD/cyrus-imapd-3.0.4'
imap/http_caldav.c: In function 'icaltime_from_rfc3339_string':
imap/http_caldav.c:2034:8: error: 'struct icaltimetype' has no member named 'is_utc'; did you mean 'is_date'?
     tt.is_utc = 1;
        ^~~~~~
        is_date

This seems to be caused by upgrading libical-devel from 2.0.0-12.fc27 to 3.0.0-1.fc28.

Comment 1 Jason Tibbitts 2017-11-14 16:35:01 UTC
Yes, this is known.  Currently waiting for the compat package to hit and have been poking upstream about it.  Cyrus and libical share developers so I didn't expect this.

Comment 2 Jason Tibbitts 2017-11-14 19:08:12 UTC
Fixed with cyrus-imapd-3.0.4-3.fc28: https://koji.fedoraproject.org/koji/taskinfo?taskID=23124424


Note You need to log in before you can comment on or make changes to this bug.