Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512847 - sosreport jars plugin gets killed by kernel
Summary: sosreport jars plugin gets killed by kernel
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: sos
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Bonazzola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:40 UTC by Marius Vollmer
Modified: 2017-11-14 15:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 15:31:01 UTC


Attachments (Terms of Use)
strace output of "sosreport -o jars --batch" (deleted)
2017-11-14 09:40 UTC, Marius Vollmer
no flags Details

Description Marius Vollmer 2017-11-14 09:40:57 UTC
Created attachment 1351847 [details]
strace output of "sosreport -o jars --batch"

Description of problem:

On one of my virtual machines (but not others), the sosreport jars plugin gets a spontaneous SIGKILL.

Version-Release number of selected component (if applicable):
kernel-4.13.10-200.fc26.x86_64
sos-3.4-1.fc26.noarch

How reproducible:
Always

Steps to Reproduce:
1. sosreport -o jars --batch

Actual results:
# sosreport -o jars --batch

sosreport (version 3.4)

This command will collect system configuration and diagnostic
information from this Fedora system. An archive containing the collected
information will be generated in /var/tmp/sos.h4_8qywy.

For more information on the Fedora Project visit:

  https://fedoraproject.org/

The generated archive may contain data considered sensitive and its
content should be reviewed by the originating organization before being
passed to any third party.

No changes will be made to system configuration.


 Setting up archive ...
 Setting up plugins ...
Killed

From the journal:

Nov 14 11:38:21 f26 kernel: BUG: unable to handle kernel paging request at ffffffffff600fea
Nov 14 11:38:21 f26 kernel: IP: read_kcore+0x30b/0x3c0
Nov 14 11:38:21 f26 kernel: PGD ee0c067 
Nov 14 11:38:21 f26 kernel: P4D ee0c067 
Nov 14 11:38:21 f26 kernel: PUD ee0e067 
Nov 14 11:38:21 f26 kernel: PMD 7ff2a067 
Nov 14 11:38:21 f26 kernel: PTE 800000000ee04165
Nov 14 11:38:21 f26 kernel: 
Nov 14 11:38:21 f26 kernel: Oops: 0001 [#5] SMP
Nov 14 11:38:21 f26 kernel: Modules linked in: ipt_MASQUERADE nf_nat_masquerade_ipv4 xt_addrtype br_netfilter overlay binfmt_misc rpcsec_gss_krb5 nfsv4 dns_resolver nfs lockd grace fscache ip6t
Nov 14 11:38:21 f26 kernel:  virtio_net virtio_blk virtio_console virtio_scsi crc32c_intel qxl drm_kms_helper serio_raw ata_generic ttm drm qemu_fw_cfg pata_acpi virtio_pci virtio_rng virtio_ri
Nov 14 11:38:21 f26 kernel: CPU: 0 PID: 12773 Comm: sosreport Tainted: G      D         4.13.10-200.fc26.x86_64 #1
Nov 14 11:38:21 f26 kernel: Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS 1.10.2-1.fc26 04/01/2014
Nov 14 11:38:21 f26 kernel: task: ffff983f221b8000 task.stack: ffffb68641664000
Nov 14 11:38:21 f26 kernel: RIP: 0010:read_kcore+0x30b/0x3c0
Nov 14 11:38:21 f26 kernel: RSP: 0018:ffffb68641667dd0 EFLAGS: 00010212
Nov 14 11:38:21 f26 kernel: RAX: 0000000000000001 RBX: 0000000000000016 RCX: ffff983f2a221000
Nov 14 11:38:21 f26 kernel: RDX: 0000001000000001 RSI: 00003fffffe00000 RDI: 0000000000000000
Nov 14 11:38:21 f26 kernel: RBP: ffffb68641667e20 R08: 00003ffffffff000 R09: 00003ffffffff000
Nov 14 11:38:21 f26 kernel: R10: 0000000000000000 R11: ffff983f221b8000 R12: 00007f104da34a60
Nov 14 11:38:21 f26 kernel: R13: 0000000000000016 R14: ffffffffff600fea R15: ffffb68641667f18
Nov 14 11:38:21 f26 kernel: FS:  00007f1053900700(0000) GS:ffff983f3fc00000(0000) knlGS:0000000000000000
Nov 14 11:38:21 f26 kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Nov 14 11:38:21 f26 kernel: CR2: ffffffffff600fea CR3: 000000003d4b5000 CR4: 00000000003406f0
Nov 14 11:38:21 f26 kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Nov 14 11:38:21 f26 kernel: DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
Nov 14 11:38:21 f26 kernel: Call Trace:
Nov 14 11:38:21 f26 kernel:  proc_reg_read+0x42/0x70
Nov 14 11:38:21 f26 kernel:  __vfs_read+0x37/0x160
Nov 14 11:38:21 f26 kernel:  ? security_file_permission+0x9b/0xc0
Nov 14 11:38:21 f26 kernel:  vfs_read+0x8e/0x130
Nov 14 11:38:21 f26 kernel:  SyS_read+0x55/0xc0
Nov 14 11:38:21 f26 kernel:  entry_SYSCALL_64_fastpath+0x1a/0xa5
Nov 14 11:38:21 f26 kernel: RIP: 0033:0x7f1052f81270
Nov 14 11:38:21 f26 kernel: RSP: 002b:00007ffc39ff7598 EFLAGS: 00000246 ORIG_RAX: 0000000000000000
Nov 14 11:38:21 f26 kernel: RAX: ffffffffffffffda RBX: 0000000000000005 RCX: 00007f1052f81270
Nov 14 11:38:21 f26 kernel: RDX: 0000000000000017 RSI: 00007f104da34a60 RDI: 0000000000000005
Nov 14 11:38:21 f26 kernel: RBP: 000055bd04bd7cc0 R08: 00007f104da34a40 R09: 00007f104df3e000
Nov 14 11:38:21 f26 kernel: R10: 00007f10536971e0 R11: 0000000000000246 R12: 00007f1053900690
Nov 14 11:38:21 f26 kernel: R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
Nov 14 11:38:21 f26 kernel: Code: ba 01 00 00 00 4c 89 ee e8 c3 38 f7 ff 48 8b 75 b8 4c 89 ea 4c 89 e7 e8 04 0d 14 00 48 85 c0 0f 84 77 fe ff ff eb b9 48 8b 4d b8 <49> 8b 06 4c 89 f6 48 89 01 4
Nov 14 11:38:21 f26 kernel: RIP: read_kcore+0x30b/0x3c0 RSP: ffffb68641667dd0
Nov 14 11:38:21 f26 kernel: CR2: ffffffffff600fea
Nov 14 11:38:21 f26 kernel: ---[ end trace 4765625af5600819 ]---


Expected results:
sosreport doesn't get killed

Additional info:

Comment 1 Marius Vollmer 2017-11-14 09:43:48 UTC
Looks like the plugin goes fishing in the Docker images, finds a link to /proc/kcore, and tries to read that.

Comment 2 Bryn M. Reeves 2017-11-14 14:36:31 UTC
This should be fixed in 3.5 - the version you are running is missing the following commits:

commit d33c63a230092e94f966551968c51e8c5760742f
Author: Michal Srb <michal@redhat.com>
Date:   Mon Aug 21 18:11:04 2017 +0200

    [jars] Catch zipfile.BadZipfile exception

commit 6fc42802b87f95dba1d6bfda49ae158143e7799c
Author: Michal Srb <michal@redhat.com>
Date:   Mon Aug 21 16:29:23 2017 +0200

    [jars] Scan only /usr/{share,lib}/java by default

We only released a new tarball containing these fixes a couple of weeks ago - I'm not sure when Sandro plans to update the Fedora builds, but this should be addressed by that.

Comment 3 Sandro Bonazzola 2017-11-14 15:31:01 UTC
Yes, I was on PTO last week and didn't notice the 3.5 version being released.
Closing this with UPSTREAM resolution and will build 3.5 this week.


Note You need to log in before you can comment on or make changes to this bug.