Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512844 - cache_restore tool may corrupt cache metadata
Summary: cache_restore tool may corrupt cache metadata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-persistent-data
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks: 1515109
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:36 UTC by Marian Csontos
Modified: 2018-04-10 13:18 UTC (History)
8 users (show)

Fixed In Version: device-mapper-persistent-data-0.7.3-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Previously, the cache_restore utility passed incorrect arguments to a function. Additionally, it missed a call to flush dirty bits when version 2 metadata of the cache was used. As a consequence, the utility corrupted the cache metadata. With this update, cache_restore now handles the arguments correctly and adds the missing call. As a result, the utility no longer corrupts version 2 metadata.
Clone Of:
: 1515109 (view as bug list)
Environment:
Last Closed: 2018-04-10 13:18:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0776 None None None 2018-04-10 13:18:47 UTC

Description Marian Csontos 2017-11-14 09:36:38 UTC
Description of problem:
Under some circumstances cache_restore tool corrupts metadata.

Version-Release number of selected component (if applicable):
device-mapper-persistent-data-0.7.3

Sorry for being so vague. Waiting for devel to fill in reproducer.

Comment 2 Joe Thornber 2017-11-14 09:43:31 UTC
v0.7.0 of the tools introduced support for cache metadata v2.

However cache restore was not writing a crucial field to the superblock.  So the kernel cannot load the metadata.

This patch fixes it:

https://github.com/jthornber/thin-provisioning-tools/commit/e3b7d825696c23c23f6bd867de4dbda69be38db8

The bug wasn't discovered for a long time because a separate bug meant v1 metadata was always being written even if v2 was requested.

v0.7.5 behaves correctly.

Comment 5 Jakub Krysl 2017-11-20 13:30:10 UTC
before:
# cache_restore -V
0.7.0-0.1.rc6.el7
# cache_restore -i metadata -o /dev/mapper/vgtest-swapvol --debug-override-metadata-version 2
cache_restore: /usr/include/boost/optional/optional.hpp:631: boost::optional<T>::reference_type boost::optional<T>::get() [with T = long unsigned int; boost::optional<T>::reference_type = long unsigned int&]: Assertion `this->is_initialized()' failed.
Aborted (core dumped)

with this patch:
# cache_restore -V
0.7.0-0.1.rc6.el7_4.1
# cache_restore -i metadata -o /dev/mapper/vgtest-swapvol --debug-override-metadata-version 2
Restoring: [==================================================]   100%

Comment 8 errata-xmlrpc 2018-04-10 13:18:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0776


Note You need to log in before you can comment on or make changes to this bug.