Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512843 - Container Nodes are not being archived in DB after deletion
Summary: Container Nodes are not being archived in DB after deletion
Keywords:
Status: CLOSED DUPLICATE of bug 1460401
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.0
Assignee: Barak
QA Contact: Pavel Zagalsky
URL:
Whiteboard:
Depends On:
Blocks: 1460401
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:36 UTC by Pavel Zagalsky
Modified: 2017-12-05 15:20 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-19 16:08:01 UTC
Category: ---
Cloudforms Team: Container Management


Attachments (Terms of Use)
Queries (deleted)
2017-11-14 09:36 UTC, Pavel Zagalsky
no flags Details

Description Pavel Zagalsky 2017-11-14 09:36:17 UTC
Created attachment 1351846 [details]
Queries

Description of problem:
Following change in: https://bugzilla.redhat.com/show_bug.cgi?id=1460401
After the node was deleted in OSE it's not being archived in the DB

Version-Release number of selected component (if applicable):
5.9.0.9

How reproducible:
Always

Steps to Reproduce:
1. Log into the appliance's console
2. Run psql vmdb_production
3. Run SELECT * FROM container_nodes; and check all the nodes are here
4. Log into OSE and delete a node with: $ oc delete node <node>
5. Open Appliance’s GUI, refresh the provider
6. Check that the recently removed node was removed in GUI as well
7. Run SELECT * FROM container_nodes; and check all the nodes are still here, incl. the one that was just removed in OSE

Actual results:
The node that was removed in OSE was removed from the DB as well

Expected results:
The node should remain in the DB even after it was deleted in OSE

Additional info:
Attached query result before and after deletion.
For further details please contact me

Comment 2 Oleg Barenboim 2017-11-14 09:43:10 UTC
Why is the severity high?  Was this functionality available before (i.e. regression) or is this an RFE?

Comment 3 Pavel Zagalsky 2017-11-14 12:11:15 UTC
This is the original RFE:
https://bugzilla.redhat.com/show_bug.cgi?id=1460401
Its' severity is High

Comment 4 Greg Blomquist 2017-11-15 22:31:15 UTC
Pavel, is this just a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1460401 ?

Comment 5 Pavel Zagalsky 2017-11-15 23:22:48 UTC
Greg, that was the requirement: https://bugzilla.redhat.com/show_bug.cgi?id=1460401, this is bug with the details. Do you think they should be merged?

Comment 6 Barak 2017-11-19 16:08:01 UTC

*** This bug has been marked as a duplicate of bug 1460401 ***


Note You need to log in before you can comment on or make changes to this bug.