Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512836 - RFE: Fix virt-v2v -o rhv to use direct upload
Summary: RFE: Fix virt-v2v -o rhv to use direct upload
Keywords:
Status: CLOSED DUPLICATE of bug 1557273
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:11 UTC by Richard W.M. Jones
Modified: 2018-03-21 10:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-21 10:43:51 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2017-11-14 09:11:31 UTC
Description of problem:

http://libguestfs.org/virt-v2v.1.html#output-to-rhv

Currently -o rhv uses the oVirt/RHV Export Storage Domain (ESD).
This concept has been deprecated and is going to be removed.

There are APIs for creating guests and uploading disks and
we should use those instead:

https://github.com/oVirt/ovirt-engine-sdk/blob/master/sdk/examples/upload_disk.p
y
http://ovirt.github.io/ovirt-engine-api-model/
http://ovirt.github.io/ovirt-engine-api-model/master/#services/vms

Version-Release number of selected component (if applicable):

libguestfs <= 1.38 uses the ESD.

Additional info:

Should we "save" the ESD method, eg. renaming it to -o rhvesd, or
should we just remove it?

Comment 1 Richard W.M. Jones 2018-03-21 10:43:51 UTC

*** This bug has been marked as a duplicate of bug 1557273 ***


Note You need to log in before you can comment on or make changes to this bug.