Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512834 - The on/off switch in Bluetooth device manager has no effect
Summary: The on/off switch in Bluetooth device manager has no effect
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: blueberry
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:05 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2017-11-28 21:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 21:59:32 UTC


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2017-11-14 09:05:27 UTC
Description of problem:
The on/off switch in Bluetooth device manager has no effect on rfkill status for Bluetooth, device visibility or the ability to pair with devices.

Version-Release number of selected component (if applicable):
1.1.18-1.fc26

How reproducible:
Always.

Steps to Reproduce:
1. Right click the blueberry tray icon
2. Click "Open Bluetooth device manager"
3. Flip the on/off switch

Actual results:
rfkill list doesn't show any change between the switch positions, Bluetooth connections are not affected and device is visible via Bluetooth.

Expected results:
Setting the switch to "Off" should disable Bluetooth (as in rfkill block), break existing connections and disable pairing new devices.

Comment 1 leigh scott 2017-11-14 09:17:23 UTC
Can you post the output for

/usr/sbin/rfkill event

Comment 2 Dominik 'Rathann' Mierzejewski 2017-11-14 11:47:16 UTC
$ rfkill list
0: sony-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: sony-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
4: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes
10: nfc0: NFC
	Soft blocked: yes
	Hard blocked: no
12: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
$ rfkill event
1510659935.491324: idx 0 type 1 op 0 soft 1 hard 0
1510659935.491463: idx 1 type 2 op 0 soft 0 hard 0
1510659935.491469: idx 4 type 1 op 0 soft 1 hard 1
1510659935.491474: idx 10 type 8 op 0 soft 1 hard 0
1510659935.491479: idx 12 type 2 op 0 soft 0 hard 0
^C

The above command just sits there with no additional output when I flip the on/off switch.

Comment 3 Dominik 'Rathann' Mierzejewski 2017-11-14 17:07:40 UTC
Interestingly, this fixed itself after a reboot. The behaviour described above happened when I uninstalled blueman, installed blueberry and logged out and then logged in again. The on/off switch works after reboot, but I did hit a crash in bt-adapter once (filed separately as bug 1464046).

Comment 4 Dominik 'Rathann' Mierzejewski 2017-11-28 21:59:32 UTC
Let's close it, since I can't reproduce it any more.


Note You need to log in before you can comment on or make changes to this bug.