Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512832 - [3.7] Registry console pod meets CrashLoopBackOff
Summary: [3.7] Registry console pod meets CrashLoopBackOff
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Registry Console
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.0
Assignee: Peter
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1513356 1512826
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 08:59 UTC by Johnny Liu
Modified: 2017-12-18 13:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1512826
Environment:
Last Closed: 2017-12-18 13:23:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description Johnny Liu 2017-11-14 08:59:04 UTC
The same issue also happened with 3.7.
registry-console:v3.7 (40b6aa5bee20)

Change image to v3.7.6 (5ef578189d02), registry console pod is running now.

+++ This bug was initially created as a clone of Bug #1512826 +++

Description of problem
Registry console pod meets CrashLoopBackOff

Version-Release number of selected component (if applicable):
Registry console v3.6, image id 920c98e806f1
(The image 3.6.173.0.63-10 attached in errata advisory 31024 has same id)

How reproducible:
Always

Steps to Reproduce:
1. Install 3.6 OCP env that would deploy registry console
2. Check the registry console pod

Actual results:
2. Check the pod, it shows CrashLoopBackOff
# oc get pod
registry-console-1-qn7hw   0/1       CrashLoopBackOff   2         30s

# oc describe pod registry-console-1-qn7hw
    Image:		brew...:8888/openshift3/registry-console:v3.6
...
  1m		26s		6	kubelet, openshift-14...redhat.com	spec.containers{registry-console}	Warning		BackOff		Back-off restarting failed container
...
  1m		9s		7	kubelet, openshift-14...redhat.com						Warning		FailedSync	Error syncing pod

# oc logs registry-console-1-qn7hw
2017/11/14 08:29:38 Could't link /container/registry-brand to /container/os-release: exit status 1: ln: failed to create symbolic link '/container/os-release': Permission denied
#

Expected results:
2. Pod should be Running

Additional info:

Comment 1 Peter 2017-11-14 19:19:17 UTC
This has been fixed in dist-git and a new container image should be available soon.

Comment 2 Xingxing Xia 2017-11-15 07:58:54 UTC
Now v3.7.8 tag is available (v3.7 tag points to it) in brew registry
# docker images | grep registry-console
brew-...:8888/openshift3/registry-console  v3.7      2bcaa0ada9cd    4 hours ago   375.8 MB
brew-...:8888/openshift3/registry-console  v3.7.8    2bcaa0ada9cd    4 hours ago   375.8 MB

Tested it, registry console pod can be Running. Also did some regression test of registry console, basic function has no issue, project/IS creation, members adding/removing works well

Comment 6 errata-xmlrpc 2017-12-18 13:23:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.