Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512816 - Failed to create snapshot for a PVC which was used by a Pod on Openstack
Summary: Failed to create snapshot for a PVC which was used by a Pod on Openstack
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.9.0
Assignee: Tomas Smetana
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 08:09 UTC by Qin Ping
Modified: 2018-01-10 08:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-10 08:20:47 UTC


Attachments (Terms of Use)

Description Qin Ping 2017-11-14 08:09:59 UTC
Description of problem:
When a PVC was used by a Pod, creating snapshot for it will report error.

Version-Release number of selected component (if applicable):
oc v3.7.7
kubernetes v1.7.6+a08f5eeb62
features: Basic-Auth GSSAPI Kerberos SPNEGO

openshift-external-storage-snapshot-controller-0.0.1-4.git78d6339.el7.x86_64
openshift-external-storage-snapshot-provisioner-0.0.1-4.git78d6339.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Deploy an OCP cluster on openstack
2. Install packages named "openshift-external-storage-snapshot*" on all masters.
3. Start snapshot controller and provisioner on the master.
4. Create a new project mytest
5. Create a PVC named cinder-pvc with dynamic provisioning
6. Create a pod named cinder-pod using PVC cinder-pvc
7. Write some data into the PVC
8. Create a snapshot for PVC cinder-pvc
9. Check volumesnapshot and volumesnapshotdata

Actual results:
No volumesnapshotdata was created.

Expected results:
volumesnapshot and volumesnapshotdata were created successfully.

Additional info:
Delete the Pod cinder-pod and create snapshot for PVC cinder-pvc, then the volumesnapshot and volumesnapshotdata were created successfully.

snapshot-controller logs:
E1114 02:32:35.999455   62309 openstack_snapshots.go:163] Failed to snapshot volume acdc4f00-1719-489a-950e-e3bd6dd0f824 : Invalid request due to incorrect syntax or missing required parameters.
W1114 02:32:35.999585   62309 snapshotter.go:292] failed to snapshot &v1.PersistentVolumeSpec{Capacity:v1.ResourceList{"storage":resource.Quantity{i:resource.int64Amount{value:4294967296, scale:0}, d:resource.infDecAmount{Dec:(*inf.Dec)(nil)}, s:"4Gi", Format:"BinarySI"}}, PersistentVolumeSource:v1.PersistentVolumeSource{GCEPersistentDisk:(*v1.GCEPersistentDiskVolumeSource)(nil), AWSElasticBlockStore:(*v1.AWSElasticBlockStoreVolumeSource)(nil), HostPath:(*v1.HostPathVolumeSource)(nil), Glusterfs:(*v1.GlusterfsVolumeSource)(nil), NFS:(*v1.NFSVolumeSource)(nil), RBD:(*v1.RBDVolumeSource)(nil), ISCSI:(*v1.ISCSIVolumeSource)(nil), Cinder:(*v1.CinderVolumeSource)(0xc4208dd890), CephFS:(*v1.CephFSVolumeSource)(nil), FC:(*v1.FCVolumeSource)(nil), Flocker:(*v1.FlockerVolumeSource)(nil), FlexVolume:(*v1.FlexVolumeSource)(nil), AzureFile:(*v1.AzureFileVolumeSource)(nil), VsphereVolume:(*v1.VsphereVirtualDiskVolumeSource)(nil), Quobyte:(*v1.QuobyteVolumeSource)(nil), AzureDisk:(*v1.AzureDiskVolumeSource)(nil), PhotonPersistentDisk:(*v1.PhotonPersistentDiskVolumeSource)(nil), PortworxVolume:(*v1.PortworxVolumeSource)(nil), ScaleIO:(*v1.ScaleIOVolumeSource)(nil), Local:(*v1.LocalVolumeSource)(nil), StorageOS:(*v1.StorageOSPersistentVolumeSource)(nil)}, AccessModes:[]v1.PersistentVolumeAccessMode{"ReadWriteOnce"}, ClaimRef:(*v1.ObjectReference)(0xc420353dc0), PersistentVolumeReclaimPolicy:"Delete", StorageClassName:"standard"}, err: Invalid request due to incorrect syntax or missing required parameters.

Comment 1 Tomas Smetana 2017-11-14 11:15:08 UTC
Cinder is not a backend we plan to support in the tech preview. Not that this bug was not real but it can't qualify as a blocker.


Note You need to log in before you can comment on or make changes to this bug.