Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512810 - Installation should fail immediately when necessary package not successfully installed
Summary: Installation should fail immediately when necessary package not successfully ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.7.z
Assignee: Russell Teague
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 07:34 UTC by Gaoyun Pei
Modified: 2018-04-05 09:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Single host failures for installing packages were not resulting in a failed playbook run Consequence: The playbook would continue and fail at a later point Fix: Added a play directive to cause the playbook to fail immediately if there were any host failures. Result: If package installation fails for any host, the playbook will fail immediately.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:32:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:32:45 UTC

Description Gaoyun Pei 2017-11-14 07:34:06 UTC
Description of problem:
When necessary package were not installed successfully on etcd host, installation was still continuing until another error encountered. This is a regression test scenario coming from https://bugzilla.redhat.com/show_bug.cgi?id=1348846


TASK [Ensure openshift-ansible installer package deps are installed] ********************************************************************************************************
ok: [openshift-138.lab.sjc.redhat.com] => (item=iproute)
ok: [openshift-125.lab.sjc.redhat.com] => (item=iproute)
ok: [openshift-145.lab.sjc.redhat.com] => (item=iproute)
ok: [openshift-138.lab.sjc.redhat.com] => (item=dbus-python)
ok: [openshift-145.lab.sjc.redhat.com] => (item=dbus-python)
ok: [openshift-125.lab.sjc.redhat.com] => (item=dbus-python)
ok: [openshift-125.lab.sjc.redhat.com] => (item=PyYAML)
ok: [openshift-138.lab.sjc.redhat.com] => (item=PyYAML)
ok: [openshift-145.lab.sjc.redhat.com] => (item=PyYAML)
failed: [openshift-138.lab.sjc.redhat.com] (item=yum-utils) => {"changed": false, "failed": true, "item": "yum-utils", "msg": "No package matching 'yum-utils' found available, installed or updated", "rc": 126, "results": ["No package matching 'yum-utils' found available, installed or updated"]}
changed: [openshift-125.lab.sjc.redhat.com] => (item=yum-utils)
changed: [openshift-145.lab.sjc.redhat.com] => (item=yum-utils)

TASK [Ensure various deps for running system containers are installed] ******************************************************************************************************
skipping: [openshift-145.lab.sjc.redhat.com] => (item=atomic) 
skipping: [openshift-145.lab.sjc.redhat.com] => (item=ostree) 
skipping: [openshift-145.lab.sjc.redhat.com] => (item=runc) 
skipping: [openshift-125.lab.sjc.redhat.com] => (item=atomic) 
skipping: [openshift-125.lab.sjc.redhat.com] => (item=ostree) 
skipping: [openshift-125.lab.sjc.redhat.com] => (item=runc) 

...

TASK [etcd : fail] **********************************************************************************************************************************************************
fatal: [openshift-145.lab.sjc.redhat.com]: FAILED! => {"changed": false, "failed": true, "msg": "CA certificate /etc/etcd/ca/ca.crt doesn't exist on CA host openshift-138.lab.sjc.redhat.com. Apply 'etcd_ca' action from `etcd` role to openshift-138.lab.sjc.redhat.com.\n"}



Version-Release number of the following components:
openshift-ansible-3.7.7-1.git.0.3e1b62b.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. 
2.
3.

Actual results:
Attached the full log and ansible inventory file

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Russell Teague 2018-01-22 22:03:05 UTC
Proposed: https://github.com/openshift/openshift-ansible/pull/6822

Comment 4 Russell Teague 2018-01-24 13:11:00 UTC
Merged

Comment 6 Gaoyun Pei 2018-01-25 07:01:32 UTC
Test this issue with openshift-ansible-3.7.26-1.git.0.f87f1af.el7.noarch.rpm

Installer quit immediately when required package not available.

TASK [Ensure openshift-ansible installer package deps are installed] ***********
Thursday 25 January 2018  06:46:26 +0000 (0:00:00.030)       0:00:30.709 ****** 
ok: [ec2-54-237-242-109.compute-1.amazonaws.com] => (item=iproute) => {"attempts": 1, "changed": false, "item": "iproute", "msg": "", "rc": 0, "results": ["iproute-3.10.0-87.el7.x86_64 providing iproute is already installed"]}
ok: [ec2-34-230-15-187.compute-1.amazonaws.com] => (item=iproute) => {"attempts": 1, "changed": false, "item": "iproute", "msg": "", "rc": 0, "results": ["iproute-3.10.0-87.el7.x86_64 providing iproute is already installed"]}
ok: [ec2-54-237-242-109.compute-1.amazonaws.com] => (item=dbus-python) => {"attempts": 1, "changed": false, "item": "dbus-python", "msg": "", "rc": 0, "results": ["dbus-python-1.1.1-9.el7.x86_64 providing dbus-python is already installed"]}
ok: [ec2-34-230-15-187.compute-1.amazonaws.com] => (item=dbus-python) => {"attempts": 1, "changed": false, "item": "dbus-python", "msg": "", "rc": 0, "results": ["dbus-python-1.1.1-9.el7.x86_64 providing dbus-python is already installed"]}
ok: [ec2-54-237-242-109.compute-1.amazonaws.com] => (item=PyYAML) => {"attempts": 1, "changed": false, "item": "PyYAML", "msg": "", "rc": 0, "results": ["PyYAML-3.10-11.el7.x86_64 providing PyYAML is already installed"]}
ok: [ec2-34-230-15-187.compute-1.amazonaws.com] => (item=PyYAML) => {"attempts": 1, "changed": false, "item": "PyYAML", "msg": "", "rc": 0, "results": ["PyYAML-3.10-11.el7.x86_64 providing PyYAML is already installed"]}
ok: [ec2-34-230-15-187.compute-1.amazonaws.com] => (item=yum-utils) => {"attempts": 1, "changed": false, "item": "yum-utils", "msg": "", "rc": 0, "results": ["yum-utils-1.1.31-42.el7.noarch providing yum-utils is already installed"]}
FAILED - RETRYING: Ensure openshift-ansible installer package deps are installed (2 retries left).
FAILED - RETRYING: Ensure openshift-ansible installer package deps are installed (1 retries left).
failed: [ec2-54-237-242-109.compute-1.amazonaws.com] (item=yum-utils) => {"attempts": 2, "changed": false, "item": "yum-utils", "msg": "No package matching 'yum-utils' found available, installed or updated", "rc": 126, "results": ["No package matching 'yum-utils' found available, installed or updated"]}

NO MORE HOSTS LEFT *************************************************************
	to retry, use: --limit @/home/slave5/workspace/Launch-Environment-Flexy/private-openshift-ansible/playbooks/byo/config.retry



Will move it to verified when 3.7 openshift-ansible package attached to https://errata.devel.redhat.com/advisory/32336

Comment 7 Gaoyun Pei 2018-02-08 02:27:01 UTC
Release date of advisory/32336 delayed, so mark this bug as verified with openshift-ansible-3.7.26-1.git.0.f87f1af.el7.noarch.rpm to avoid too many bugs waiting at ON_QA status.

Comment 11 errata-xmlrpc 2018-04-05 09:32:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.