Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512800 - Overlapping allocation pools are not detected by the network-environment validator
Summary: Overlapping allocation pools are not detected by the network-environment vali...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: Upstream M2
: 14.0 (Rocky)
Assignee: Florian Fuchs
QA Contact: Udi
URL:
Whiteboard:
Depends On: 1643943 1651159
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 06:56 UTC by Udi
Modified: 2019-01-11 11:49 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-validations-9.1.1-0.20180706135914.d21e7fa.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:48:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1745179 None None None 2018-01-24 16:35:02 UTC
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:49:03 UTC
OpenStack gerrit 537448 None None None 2018-01-24 16:35:30 UTC

Description Udi 2017-11-14 06:56:52 UTC
Description of problem:
I configured the following ExternalAllocationPools in my network-environment.yaml:

  ExternalAllocationPools: [{'start': '192.168.200.180', 'end': '192.168.200.190'}, {'start': '192.168.200.180', 'end': '192.168.200.200'}]

When I ran the validator I got no error, but when deploying I got a clear message about it:

Resource CREATE failed: Conflict: resources.Networks.resources.ExternalNetwork.resources.ExternalSubnet: Found overlapping allocation pools: 192.168.200.180-192.168.200.190 192.168.200.180-192.168.200.200 for subnet 192.168.200.0/24. Neutron server returns request_ids: ['req-7ec307a5-d830-4303-9c62-5176319c4a17']


Version-Release number of selected component (if applicable):
openstack-tripleo-validations-7.4.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Create an overlapping in one of the allocation pools in your network-environment.yaml
2. Don't forget to update the plan with "openstack object create overcloud environments/network-environment.yaml"
3. Run the validataor - it passes
4. Run the deployment - it fails

Comment 6 Udi 2018-10-19 07:40:20 UTC
Blocked by: https://bugzilla.redhat.com/show_bug.cgi?id=1603212 [Can't run validations]

Comment 7 Udi 2018-11-23 10:43:47 UTC
Blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1651159. The validator checks the wrong nic-configs as a result of this bug.

Comment 8 Udi 2018-11-27 12:04:04 UTC
Verified. The blocking bug is still not fixed but it appears random so I was able to verify: openstack-tripleo-validations-9.3.1-0.20181008110752.4064fb7.el7ost.noarch

Comment 10 errata-xmlrpc 2019-01-11 11:48:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.