Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512793 - fail to re-install ocp with ansible-service-catalog deployed
Summary: fail to re-install ocp with ansible-service-catalog deployed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Fabian von Feilitzsch
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 06:35 UTC by liujia
Modified: 2017-12-18 13:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 13:23:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description liujia 2017-11-14 06:35:48 UTC
Description of problem:
Run config.yml against v3.7 ocp with ansible-service-catalog deployed on it. Re-install failed at task [ansible_service_broker : create ansible-service-broker service].

fatal: [x.x.x.x]: FAILED! => {"changed": false, "failed": true, "msg": {"cmd": "/usr/bin/oc replace -f /tmp/asb-pUz9c3 -n openshift-ansible-service-broker", "results": {}, "returncode": 1, "stderr": "The Service \"asb\" is invalid: spec.clusterIP: Invalid value: \"\": field is immutable\n", "stdout": ""}}

Version-Release number of the following components:
openshift-ansible-3.7.7-1.git.0.3e1b62b.el7.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Install ocp v3.7 with asb installed by default.
openshift_service_catalog_image_prefix: x.x.x.x
ansible_service_broker_image_prefix: x.x.x.x
template_service_broker_prefix: x.x.x.x
2. Re-install
3.

Actual results:
Re-install failed.

Expected results:
Re-install succeed.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Fabian von Feilitzsch 2017-11-27 20:36:33 UTC
https://github.com/openshift/openshift-ansible/pull/6276
https://github.com/openshift/openshift-ansible/pull/6277

Should fix or work around the idempotence issues.

Comment 2 openshift-github-bot 2017-12-01 16:26:24 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/4f72e8a10da24aa231498c897db1153ef51ba2ee
Bug 1512793- Fix idempotence issues in ASB deploy

- Add support for annotations in oc_service
- Use oc_service instead of oc_obj
- Use oc_pvc instead of oc_obj
- Work around lack of idempotency for oc_obj DeploymentConfig

https://github.com/openshift/openshift-ansible/commit/e0e10698184c9a7cf4bf65787771686e46d26603
Merge pull request #6277 from fabianvf/asb-idempotence-cpick

Bug 1512793- Fix idempotence issues in ASB deploy

Comment 4 Zhang Cheng 2017-12-05 06:44:03 UTC
Verified with openshift-ansible-3.7.11-1, re-installed succeed. LGTM

Comment 7 errata-xmlrpc 2017-12-18 13:23:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.