Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512788 - Host crashed while adding 500G memory to guest with maxmem=4T
Summary: Host crashed while adding 500G memory to guest with maxmem=4T
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.5
Hardware: ppc64le
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Serhii Popovych
QA Contact: Min Deng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 06:10 UTC by Min Deng
Modified: 2017-11-15 02:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 23:53:30 UTC


Attachments (Terms of Use)
vmcore-dmesg.txt (deleted)
2017-11-14 06:13 UTC, Min Deng
no flags Details

Description Min Deng 2017-11-14 06:10:32 UTC
Description of problem:
Host crashed while adding 500G memory to guest with maxmem=4T option
Version-Release number of selected component (if applicable):
kernel-3.10.0-781.el7.ppc64le
qemu-kvm-rhev-2.10.0-5.el7.ppc64le

How reproducible:
Steps,
1.boot up guest 
/usr/libexec/qemu-kvm -name avocado-vt-vm1 -sandbox off -machine pseries -nodefaults -vga std -chardev socket,id=serial_id_serial0,path=/tmp/S,server,nowait -device spapr-vty,reg=0x30000000,chardev=serial_id_serial0 -device nec-usb-xhci,id=usb1,bus=pci.0,addr=0x3  -drive id=drive_image1,if=none,snapshot=off,aio=native,cache=none,format=qcow2,file=rhel75-ppc64-virtio.qcow2 -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=1,bus=pci.0,addr=0x4 -netdev tap,id=net0,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,vhost=on -device virtio-net-pci,netdev=net0,id=nic0,mac=52:54:00:43:17:1a,bus=pci.0,addr=0x1e -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -vnc :1 -rtc base=utc,clock=host -enable-kvm -device usb-kbd,id=input0 -device usb-mouse,id=input1 -device usb-tablet,id=input2 -monitor stdio -smp 16,sockets=8,threads=1,cores=2 -m 16G,slots=256,maxmem=4T -numa node -qmp tcp:0:4444,server,nowait

2.Add new memory to guest.
QEMU 2.10.0 monitor - type 'help' for more information
(qemu) 
(qemu) 
(qemu) 
(qemu) 
(qemu) object_add memory-backend-ram,id=mem1,size=1T
cannot set up guest memory 'mem1': Cannot allocate memory

(qemu) object_add memory-backend-ram,id=mem1,size=10G
(qemu) device_add pc-dimm,id=dimm1,memdev=mem1,slot=2

(qemu) object_add memory-backend-ram,id=mem2,size=1024G
cannot set up guest memory 'mem2': Cannot allocate memory

(qemu) object_add memory-backend-ram,id=mem2,size=100G

(qemu) object_add memory-backend-ram,id=mem3,size=1023G
cannot set up guest memory 'mem3': Cannot allocate memory

(qemu) object_add memory-backend-ram,id=mem3,size=500G
(qemu) device_add pc-dimm,id=dimm3,memdev=mem3

Write failed: Broken pipe...

Actual results:
The host crashed finally.

Expected results:
Neither host nor guest crashed.

Additional info:
[ 5790.192221] KVM guest htab at c00000f2b3000000 (order 27), LPID 1
[ 6092.448120] KVM guest htab at c00000f2bb000000 (order 28), LPID 1
[ 6092.451244] Unable to handle kernel paging request for data at address 0xd00000068a040008
[ 6092.451316] Faulting instruction address: 0xc0000000000bdd20
[ 6092.451377] Oops: Kernel access of bad area, sig: 11 [#1]
[ 6092.451424] SMP NR_CPUS=2048 NUMA PowerNV
[ 6092.451485] Modules linked in: vhost_net vhost macvtap macvlan xt_CHECKSUM iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_nat_ipv4 nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ipt_REJECT nf_reject_ipv4 tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter bridge stp llc kvm_hv kvm ses enclosure scsi_transport_sas sg shpchp ipmi_powernv ipmi_devintf leds_powernv ipmi_msghandler ibmpowernv i2c_opal powernv_rng i2c_core nfsd auth_rpcgss nfs_acl lockd grace ip_tables xfs sd_mod lpfc bnx2x nvmet_fc(T) nvmet crc_t10dif crct10dif_generic ipr nvme_fc(T) nvme_fabrics nvme_core libata scsi_transport_fc ptp pps_core mdio libcrc32c scsi_tgt crct10dif_common sunrpc dm_mirror dm_region_hash dm_log dm_mod scsi_transport_iscsi
[ 6092.453347] CPU: 88 PID: 27607 Comm: qemu-kvm Tainted: G               ------------ T 3.10.0-781.el7.ppc64le #1
[ 6092.453527] task: c000003f8b832c40 ti: c000003f5d2e4000 task.ti: c000003f5d2e4000
[ 6092.453663] NIP: c0000000000bdd20 LR: d00000006e47f794 CTR: c0000000000bdca0
[ 6092.453800] REGS: c000003f5d2e75b0 TRAP: 0300   Tainted: G               ------------ T  (3.10.0-781.el7.ppc64le)
[ 6092.453980] MSR: 9000000000009033 <SF,HV,EE,ME,IR,DR,RI,LE>  CR: 44022822  XER: 00000000
[ 6092.454312] CFAR: d00000006e4830b4 DAR: d00000068a040008 DSISR: 42000000 SOFTE: 1
GPR00: d00000006e47f794 c000003f5d2e7830 c000000001230b00 c00000f28ce60000
GPR04: d00000008ca44280 d000000063eebfe0 00000000006c0428 0000000000000000
GPR08: fffffffffffffe7f 0000000060420000 d00000068a040000 d00000006e4830a0
GPR12: c0000000000bdca0 c000000007b51800 f000000035058260 000000000003f7fc
GPR16: 0000000000000000 ffffffffffff0000 d000000085e40000 0000000000010000
GPR20: 00003fff90540000 c00000bf5f008098 00000003f7fc1194 00000000006c0428
GPR24: 0000000000010000 0000000000000001 00000000006c0428 c00000f28ce60000
GPR28: d00000008ca44280 00000000006c0428 d00000008ca44280 d000000063eebfe0
[ 6092.456043] NIP [c0000000000bdd20] kvmppc_add_revmap_chain+0x80/0x1d0
[ 6092.456105] LR [d00000006e47f794] kvmppc_book3s_hv_page_fault+0xe74/0xe80 [kvm_hv]
[ 6092.456175] Call Trace:
[ 6092.456200] [c000003f5d2e7830] [c000003f5d2e7890] 0xc000003f5d2e7890 (unreliable)
[ 6092.456284] [c000003f5d2e7890] [d00000006e47f794] kvmppc_book3s_hv_page_fault+0xe74/0xe80 [kvm_hv]
[ 6092.456379] [c000003f5d2e7a10] [d00000006e479600] kvmppc_vcpu_run_hv+0x1060/0x15e0 [kvm_hv]
[ 6092.456466] [c000003f5d2e7b50] [d00000006d7d6a3c] kvmppc_vcpu_run+0x2c/0x40 [kvm]
[ 6092.456552] [c000003f5d2e7b70] [d00000006d7d358c] kvm_arch_vcpu_ioctl_run+0x5c/0x1c0 [kvm]
[ 6092.456638] [c000003f5d2e7bb0] [d00000006d7c3888] kvm_vcpu_ioctl+0x3a8/0x800 [kvm]
[ 6092.456723] [c000003f5d2e7d20] [c000000000352d88] do_vfs_ioctl+0x428/0x890
[ 6092.456793] [c000003f5d2e7dd0] [c0000000003532b4] SyS_ioctl+0xc4/0xe0
[ 6092.456864] [c000003f5d2e7e30] [c00000000000a184] system_call+0x38/0xb4
[ 6092.456933] Instruction dump:
[ 6092.456968] 793a0020 7b5c26e4 7c7b1b78 7f8ae214 409e00a0 813c000c 792926e4 7d4a4a14
[ 6092.457085] 935e0008 7bbd0020 813c000c 913e000c <93aa0008> 93bc000c 48000030 60420000
[ 6092.457205] ---[ end trace 93fcc7c1f133078f ]---

Comment 1 Min Deng 2017-11-14 06:13:00 UTC
Created attachment 1351790 [details]
vmcore-dmesg.txt

Hostname:ibm-p8-rhevm-03.lab.eng.bos.redhat.com
[root@ibm-p8-rhevm-03 home]# free -m
              total        used        free      shared  buff/cache   available
Mem:        1042435       43441      995082          29        3911      996326
Swap:          4095           0        4095

Comment 2 Laurent Vivier 2017-11-14 15:22:56 UTC
The error seems to be triggered by the HPT resize:

...
[ 5790.192221] KVM guest htab at c00000f2b3000000 (order 27), LPID 1
[ 6092.448120] KVM guest htab at c00000f2bb000000 (order 28), LPID 1
[ 6092.451244] Unable to handle kernel paging request for data at address 0xd00000068a040008
[ 6092.451316] Faulting instruction address: 0xc0000000000bdd20
...

Comment 3 Laurent Vivier 2017-11-14 16:39:22 UTC
looks like a duplicate of BZ1510771

Comment 4 David Gibson 2017-11-14 23:53:30 UTC
Yes, I'm pretty sure this is the same as bug 1510771.

*** This bug has been marked as a duplicate of bug 1510771 ***


Note You need to log in before you can comment on or make changes to this bug.