Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512787 - SELinux is preventing lircd from 'execute' accesses on the file /usr/bin/bash.
Summary: SELinux is preventing lircd from 'execute' accesses on the file /usr/bin/bash.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e8b7544126345db8851c20486bd...
: 1487958 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 06:10 UTC by Robert Hancock
Modified: 2017-11-20 16:56 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-283.16.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 16:56:36 UTC


Attachments (Terms of Use)

Description Robert Hancock 2017-11-14 06:10:02 UTC
Description of problem:
SELinux is preventing lircd from 'execute' accesses on the file /usr/bin/bash.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that lircd should be allowed execute access on the bash file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'lircd' --raw | audit2allow -M my-lircd
# semodule -X 300 -i my-lircd.pp

Additional Information:
Source Context                system_u:system_r:lircd_t:s0
Target Context                system_u:object_r:shell_exec_t:s0
Target Objects                /usr/bin/bash [ file ]
Source                        lircd
Source Path                   lircd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           bash-4.4.12-7.fc26.x86_64
Policy RPM                    selinux-policy-3.13.1-260.9.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.12.14-300.fc26.x86_64 #1 SMP Wed
                              Sep 20 16:28:07 UTC 2017 x86_64 x86_64
Alert Count                   12
First Seen                    2017-08-21 20:56:20 CST
Last Seen                     2017-09-22 19:37:13 CST
Local ID                      4e178473-6b68-499c-a2ee-e3e8a5e2fb26

Raw Audit Messages
type=AVC msg=audit(1506130633.120:122): avc:  denied  { execute } for  pid=967 comm="lircd" name="bash" dev="dm-1" ino=436097 scontext=system_u:system_r:lircd_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file permissive=0


Hash: lircd,lircd_t,shell_exec_t,file,execute

Version-Release number of selected component:
selinux-policy-3.13.1-260.9.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.12-300.fc27.x86_64
type:           libreport

Potential duplicate: bug 1487958

Comment 1 Lukas Vrabec 2017-11-16 12:04:12 UTC
*** Bug 1487958 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2017-11-16 15:12:12 UTC
selinux-policy-3.13.1-283.16.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5178e6a393

Comment 3 Fedora Update System 2017-11-17 18:56:17 UTC
selinux-policy-3.13.1-283.16.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5178e6a393

Comment 4 Fedora Update System 2017-11-20 16:56:36 UTC
selinux-policy-3.13.1-283.16.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.