Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512717 - Corrupt Sandbox Checkpoint Files
Summary: Corrupt Sandbox Checkpoint Files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.z
Assignee: Seth Jennings
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On: 1509799 1540606 1540608
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 22:51 UTC by Eric Paris
Modified: 2018-06-25 18:49 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1509799
Environment:
Last Closed: 2018-04-05 09:30:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:31:32 UTC

Comment 2 Eric Paris 2017-11-13 23:13:02 UTC
We saw a pod, with 44 of these completely break. It's like it just stopped making forward progress. I ran:

oc get --raw /debug/pprof/profile --server=https://172.31.71.195:10250 > profile

and it hung for about a hour. top showed 'openshift' using 100% CPU. I deleted the 'bad' sandboxes, restarted node, and now the node seems largely ok...

Comment 3 Seth Jennings 2017-11-13 23:13:34 UTC
Upstream PR:
https://github.com/kubernetes/kubernetes/pull/55641

Comment 4 Seth Jennings 2017-11-14 15:10:23 UTC
Origin PR:
https://github.com/openshift/origin/pull/17302

Comment 6 weiwei jiang 2018-01-25 07:26:28 UTC
Checked with 
# openshift version 
openshift v3.7.26
kubernetes v1.7.6+a08f5eeb62
etcd 3.2.8

And can not reproduce this issue, so verify this.

Comment 10 errata-xmlrpc 2018-04-05 09:30:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.