Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512684 - Redfish driver should read node boot mode
Summary: Redfish driver should read node boot mode
Keywords:
Status: CLOSED DUPLICATE of bug 1512686
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 14.0 (Rocky)
Assignee: Ilya Etingof
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 20:38 UTC by Ilya Etingof
Modified: 2018-06-21 11:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-21 11:28:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 528314 None None None 2018-02-02 15:39:39 UTC
Launchpad 1731013 None None None 2017-11-13 20:38:49 UTC

Description Ilya Etingof 2017-11-13 20:38:49 UTC
Ironic Redfish driver does not currently read boot mode (BootSourceOverrideMode element) as set to the node. When a node is configured to boot over UEFI, Ironic would not understand that and hence would serve the wrong NBP.

This bug is to modify Ironic Redfish driver to utilize sushy library to read and propagate the actual boot mode.

Comment 1 Bob Fournier 2017-12-01 19:31:08 UTC
Ilya - I put this for OSP-13, please change if not correct.

Comment 3 Ilya Etingof 2018-02-02 15:35:27 UTC
https://review.openstack.org/#/c/528314/

Comment 8 Ilya Etingof 2018-06-21 11:28:24 UTC

*** This bug has been marked as a duplicate of bug 1512686 ***


Note You need to log in before you can comment on or make changes to this bug.