Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512621 - Misleading error message as "Failed to install Host. HA client was not imported" while adding additional HE host
Summary: Misleading error message as "Failed to install Host. HA client was not import...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-host-deploy
Version: 4.1.7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ido Rosenzwig
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1549489
TreeView+ depends on / blocked
 
Reported: 2017-11-13 16:49 UTC by nijin ashok
Modified: 2018-05-15 17:56 UTC (History)
9 users (show)

Fixed In Version: ovirt-host-deploy-1.7.0-1.el7ev
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1549489 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:55:52 UTC
oVirt Team: Integration


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84261 master MERGED src: plugins: Try to import from hosted-engine-ha once more 2017-11-22 14:37:18 UTC
oVirt gerrit 88225 ovirt-host-deploy-1.6 MERGED src: plugins: Try to import from hosted-engine-ha once more 2018-02-27 12:56:25 UTC
Red Hat Knowledge Base (Solution) 3245511 None None None 2017-11-20 05:07:42 UTC
Red Hat Product Errata RHEA-2018:1512 None None None 2018-05-15 17:56:09 UTC

Description nijin ashok 2017-11-13 16:49:18 UTC
Description of problem:

While adding additional HE host, the events pane in the RHV-M portal will show below error log.

Failed to install Host. HA client was not imported.

However, the installation will proceed fine and HE host will be deployed successfully. The error occurs only with RHEL host since ovirt-hosted-engine-ha package will only be installed during the deployment process. 

It will not happen with RHV-H since ovirt-hosted-engine-ha will be pre-installed in RHV-H and hence client module will be always available.

Relavent logs.

====
2017-11-13 21:49:02,717+05 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (VdsDeploy) [2f7f70f5] EVENT_ID: VDS_INSTALL_IN_PROGRESS(509), Correlation ID: 2f7f70f5, Call Stack: null, Custom ID: null, Custom Event ID: -1, Message: Installing Host . Yum Verify: 6/6: ovirt-hosted-engine-ha.noarch 0:2.1.7-1.el7ev - u.
2017-11-13 21:49:03,606+05 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (VdsDeploy) [2f7f70f5] EVENT_ID: VDS_INSTALL_IN_PROGRESS_ERROR(511), Correlation ID: 2f7f70f5, Call Stack: null, Custom ID: null, Custom Event ID: -1, Message: Failed to install Host . HA client was not imported.
====


Version-Release number of selected component (if applicable):

ovirt-host-deploy-1.6.7-1.el7ev.noarch
rhevm-4.1.7.6-0.1.el7.noarch

How reproducible:

100%

Steps to Reproduce:

1. Add an additional HE RHEL host and watch the events tab. Make sure that host is not having the ovirt-hosted-engine-ha before adding to RHV-M.


Actual results:

Misleading error message as "Failed to install Host" which confuses users.

Expected results:
 

Additional info:

Comment 3 Nikolai Sednev 2017-11-30 13:15:59 UTC
1.Deployed SHE over Gluster.
2.Added NFS data storage domain.
3.Got SHE storage domain and SHE-VM auto-imported.
4.Added additional clean ha-host without ovirt-hosted-engine-setup previously installed on it.
5.Additional ha-host became active as ha-host.
6.Original error wasn't reproduced.

Tested on these components:
ovirt-hosted-engine-ha-2.2.0-0.0.master.20171128125909.20171128125907.gitfa5daa6.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.0-0.0.master.20171129192644.git440040c.el7.centos.noarch
ovirt-engine-appliance-4.2-20171129.1.el7.centos.noarch

Moving to verified.

Comment 8 errata-xmlrpc 2018-05-15 17:55:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1512


Note You need to log in before you can comment on or make changes to this bug.