Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 151262 - random user space segfaults with exec-shield-randomize
Summary: random user space segfaults with exec-shield-randomize
Keywords:
Status: CLOSED DUPLICATE of bug 154759
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 153271 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-03-16 15:21 UTC by Harald Hoyer
Modified: 2015-01-04 22:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-08 01:50:13 UTC


Attachments (Terms of Use)

Description Harald Hoyer 2005-03-16 15:21:26 UTC
$ uname -r
2.6.11-1.1177_FC4smp

ntpd randomly segfaults, compiled with the default RPM_OPT_FLAGS...
turning off exec-shield-randomize cures the segfaults

valgrind, efence do not show anything wrong..

a small test app:
int main(int argc, char **argv)
{
        return 0;
}

compiled with gcc4 and -fstack-check 
 gcc -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -mtune=pentium4
-g -DDEBUG -D_FORTIFYSOURCE=2 -Wall  -Wall -Wcast-qual -Wmissing-prototypes
-Wpointer-arith -Wshadow -Wstrict-prototypes -fstack-check -o main main.c

segfaults also randomly with exec-shield-randomize

Comment 1 Harald Hoyer 2005-03-16 15:22:21 UTC
problem with gcc, glibc or kernel??

Comment 2 Harald Hoyer 2005-03-16 15:37:25 UTC
ok, forget the -fstack-check


Comment 3 Harald Hoyer 2005-03-16 16:26:33 UTC
ntpd compiled with gcc32, same symptoms...

Comment 4 Russell Coker 2005-04-10 17:20:44 UTC
*** Bug 153271 has been marked as a duplicate of this bug. ***

Comment 5 Warren Togami 2005-04-10 19:21:05 UTC
What arch?


Comment 6 Russell Coker 2005-04-10 22:06:11 UTC
For me it's Intel, a P4. 

Comment 7 Harald Hoyer 2005-04-11 10:06:11 UTC
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz


Comment 8 Orion Poplawski 2005-04-26 17:57:52 UTC
I'm seeing a lot of ntpd startup failures on FC3 and ntp-4.2.0.a.20040617-4

random, e.g.:


uname({sys="Linux", node="cynosure", ...}) = 0
gettimeofday({1114538224, 941201}, NULL) = 0
gettimeofday({1114538224, 941911}, NULL) = 0
gettimeofday({1114538224, 942277}, NULL) = 0
gettimeofday({1114538224, 942659}, NULL) = 0
gettimeofday({1114538224, 943019}, NULL) = 0
gettimeofday({1114538224, 943393}, NULL) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

close(4)                                = 0
rt_sigaction(SIGSYS, {0xc5b3a0, [], SA_RESTORER, 0x1548c8}, {SIG_DFL}, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
adjtimex({modes=61, offset=-1162, freq=5172136, maxerror=16, esterror=16,
status=64, constant=0, precision=1, tolerance=33554432, time={1114538247,
657822}}) = 5
rt_sigaction(SIGSYS, {SIG_DFL}, NULL, 8) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---


Comment 9 Warren Togami 2005-04-27 00:17:32 UTC
Can someone verify if this is the same issue as Bug 154759 which affects FC3
with 2.6.11 kernel?


Comment 10 Orion Poplawski 2005-04-27 14:44:58 UTC
Looks like it to me.  Sorry about that.

Comment 11 Warren Togami 2005-05-08 01:50:13 UTC

*** This bug has been marked as a duplicate of 154759 ***


Note You need to log in before you can comment on or make changes to this bug.