Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512618 - vdo --vdoLogicalSize appears to be ignored during creation
Summary: vdo --vdoLogicalSize appears to be ignored during creation
Keywords:
Status: CLOSED DUPLICATE of bug 1510558
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vdo
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: vdo-internal
QA Contact: vdo-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 16:45 UTC by Corey Marthaler
Modified: 2019-03-06 01:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-13 17:05:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Corey Marthaler 2017-11-13 16:45:30 UTC
Description of problem:
The underlying volume the VDO is being created on is 10G.

[root@mckinley-04 ~]# lvs -a /dev/snapper_thinp/origin
  LV     VG            Attr       LSize  Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  origin snapper_thinp Vwi-a-t--- 10.00g POOL        1.41                                   

# Shouldn't the created Logical size be either 20G, or a warning printed that the supplied 20G option wont work? 
[root@mckinley-04 ~]# vdo create --name virt_vdovolume --vdoLogicalSize 20G --device /dev/snapper_thinp/origin
Creating VDO virt_vdovolume
Starting VDO virt_vdovolume
Starting compression on VDO virt_vdovolume
VDO instance 31 volume is ready at /dev/mapper/virt_vdovolume

[root@mckinley-04 ~]# vdo status | grep " size" 
    Logical size: 10G
    Physical size: 10G



Version-Release number of selected component (if applicable):
vdo-6.1.0.34-8    BUILT: Fri Nov  3 06:58:45 CDT 2017
kmod-kvdo-6.1.0.34-7.el7    BUILT: Fri Nov  3 06:44:06 CDT 2017

Comment 2 Bryan Gurney 2017-11-13 17:05:31 UTC
This is actually a duplicate of BZ 1510558.  It's not a case of  the "--vdoLogicalSize" option being ignored, but the previous metadata is on disk, because the "vdoformat" command didn't actually run.

*** This bug has been marked as a duplicate of bug 1510558 ***


Note You need to log in before you can comment on or make changes to this bug.