Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512576 - Certification suite is not sensing notebook coming back from suspend mode.
Summary: Certification suite is not sensing notebook coming back from suspend mode.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware
Version: 1.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: brose
QA Contact: rhcert qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 15:01 UTC by FIT
Modified: 2018-11-01 17:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 17:25:47 UTC


Attachments (Terms of Use)
SOSREPORT file (deleted)
2017-11-24 15:56 UTC, FIT
no flags Details
Video showing suspend test part 1 (deleted)
2018-01-16 12:20 UTC, FIT
no flags Details
Video showing suspend test part 2 (deleted)
2018-01-16 12:21 UTC, FIT
no flags Details
Replacement for Suspend Test part 2 (deleted)
2018-01-16 12:25 UTC, FIT
no flags Details
SOS Report File just after running suspend test (deleted)
2018-01-19 16:37 UTC, FIT
no flags Details
SOSReport file just after suspend mode (deleted)
2018-01-19 16:54 UTC, FIT
no flags Details
Suspend Test Video (deleted)
2018-01-29 18:30 UTC, FIT
no flags Details

Description FIT 2017-11-13 15:01:23 UTC
Description of problem:

During Suspend Test at the phase that will test Fn+key to suspend mode, certification suite is not sensing the notebook coming back from suspend mode.

How reproducible:

Install Red Hat 7.4, install latest certification test version and start suspend test.

Actual results:
After Fn+key phase, test will fail.

Certification Suite questions if notebook have Fn+key to enter in Suspend Mode.

I answer yes to that question.

Then, Certification Suite asks to press Fn+key to enter in suspend mode (it stops waiting for Yes or No to perform the keystroke).

I answer "Yes" and with no time to press Fn+key Certification Suite immediately questions if system came back from suspend mode.

I then press Fn+key to enter suspend mode. I wait a few seconds to be sure the notebook is in suspend mode. I press power button to return from suspend mode and then I answer "Yes" to Certification Test.

From this point, Suspend Test will result a failure result.

Comment 1 Joseph Kachuck 2017-11-16 14:21:10 UTC
Hello Roger,
Please attach a sosreport from the system when it comes back from suspend.

Thank You
Joe Kachuck

Comment 2 FIT 2017-11-24 15:56:16 UTC
Created attachment 1358693 [details]
SOSREPORT file

Comment 3 FIT 2018-01-16 12:20:45 UTC
Created attachment 1381973 [details]
Video showing suspend test part 1

Comment 4 FIT 2018-01-16 12:21:53 UTC
Created attachment 1381974 [details]
Video showing suspend test part 2

Comment 5 FIT 2018-01-16 12:25:20 UTC
Created attachment 1381975 [details]
Replacement for Suspend Test part 2

Comment 6 FIT 2018-01-19 16:37:52 UTC
Created attachment 1383499 [details]
SOS Report File just after running suspend test

Comment 7 FIT 2018-01-19 16:54:35 UTC
Created attachment 1383516 [details]
SOSReport file just after suspend mode

Comment 9 brose 2018-01-26 02:01:14 UTC
None of the attachment videos work for me.
It sounds like you're using one machine as the LTS and the SUT.
Please confirm if this is true and if so, what happens when using separate machines and the web ui on LTS.

Thank you

Comment 10 FIT 2018-01-29 18:09:02 UTC
Hello Brose, If undertand correclty, I have a SUT and I have a test server, is that LTS? Anyway I am running SUSPEND TEST manually from SUT.

Regarding video, did you uncompressed both files to get the video? It is strange because viode works here. I will try to down the resolution to fit the 20MB file size limit and send again.

Best regards.

Comment 11 FIT 2018-01-29 18:30:32 UTC
Created attachment 1387945 [details]
Suspend Test Video

Comment 12 FIT 2018-01-29 18:33:51 UTC
I uploaded the video again, now I believe you can watch it.

Best regards.

Comment 13 FIT 2018-01-30 15:03:41 UTC
I ran the rest from server, same error.

Best regards.

Comment 14 brose 2018-05-30 18:35:13 UTC
Please try using the latest versions of 
redhat-certification
redhat-certification-backend
redhat-certification-hardware

and let us know whether you still see this.

Comment 15 Joseph Kachuck 2018-11-01 17:25:47 UTC
Hello HPi,
As no responds from the previous update. I am closing this BZ as current release.
Please reopen if this is still an issue.

Thank You
Joe Kachuck


Note You need to log in before you can comment on or make changes to this bug.