Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512574 - dropdown menu for refresh interval in dashboard is not visible
Summary: dropdown menu for refresh interval in dashboard is not visible
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-dashboard
Classification: oVirt
Component: General
Version: 1.1.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.1.8
: ---
Assignee: Scott Dickerson
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 14:59 UTC by rhev-integ
Modified: 2017-12-11 16:32 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-dashboard-1.1.8-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1510524
Environment:
Last Closed: 2017-12-11 16:32:13 UTC
oVirt Team: UX
rule-engine: ovirt-4.1+
pnovotny: testing_plan_complete-
rule-engine: devel_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83880 master MERGED Hide tooltip on refresh button when it's clicked or expanded 2017-11-13 15:00:03 UTC
oVirt gerrit 84032 ovirt-engine-dashboard-1.1 MERGED Hide tooltip on refresh button when it's clicked or expanded 2017-11-13 16:48:59 UTC

Description rhev-integ 2017-11-13 14:59:52 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1510524 +++
======================================================================

Created attachment 1349021 [details]
refresh dropdown menu

Description of problem:
The dropdown menu for refresh interval is not visible. The help is overlaping it.

Version-Release number of selected component (if applicable):
ovirt-engine-dashboard-1.2.0-0.7.20171103git5c20c87.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. click on dropdown menu next to refresh button in top left corner of dashboard


Actual results: help is displayed, dropdown menu is not visible, see attachment


Expected results: help hides after clicking on the dropdown menu

(Originally by Lucie Leistnerova)

Comment 1 rhev-integ 2017-11-13 14:59:56 UTC
"Expected results: help hides after clicking on the dropdown menu"

In webadmin (GWT), we have a global click handler that closes all tooltips onclick. We may need a similar thing in the dashboard app.

(Originally by Greg Sheremeta)

Comment 2 Greg Sheremeta 2017-11-15 00:20:32 UTC
The dropdown menu has been removed since it only had a single option that said 'manual' -- so please QA that the refresh button + tooltip works as expected, looks good, etc.

Comment 3 Pavel Novotny 2017-11-20 18:41:13 UTC
Verified in
ovirt-engine-4.1.8-0.1.el7.noarch
ovirt-engine-dashboard-1.1.8-1.el7ev.noarch


The dropdown menu has been removed and the tooltip for the refresh button works and looks as expected.


Note You need to log in before you can comment on or make changes to this bug.