Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512555 - Embedded ansible fails to enable after upgrade from 5.7 appliance
Summary: Embedded ansible fails to enable after upgrade from 5.7 appliance
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Satoe Imaishi
QA Contact: luke couzens
URL:
Whiteboard: ansible_embed:black:migration:upgrade
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 14:02 UTC by luke couzens
Modified: 2017-11-14 12:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 12:50:10 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 2 Nick Carboni 2017-11-13 17:01:11 UTC
This looks like the yum upgrade actually failed.

On the system with this issue "rpm -qa | grep ansible" shows that the ansible-tower-server package is not installed.

Additionally, "yum history info" shows the following info about the transaction:

Transaction ID : 2
Begin time     : Mon Nov 13 06:02:24 2017
Begin rpmdb    : 595:c7fae4a05e9cdb62b7139bc1dc5b414438f169d6
End time       :            06:06:26 2017 (242 seconds)
End rpmdb      : 659:64534fbf2d8d1734390405fd89b34c67980b81d8
User           : root <root>
Return-Code    : Failure: 1
Command Line   : update -y
Transaction performed with:
    Installed     rpm-4.11.3-25.el7.x86_64                  @anaconda/7.4
    Updated       subscription-manager-1.19.21-1.el7.x86_64 @anaconda/7.4
    Installed     yum-3.4.3-154.el7.noarch                  @anaconda/7.4
    Installed     yum-metadata-parser-1.1.4-10.el7.x86_64   @anaconda/7.4

Scriptlet output:
   1 Applying workaround for broken SELinux policy: https://bugzilla.redhat.com/show_bug.cgi?id=1381331
   2 /var/www/miq/vmdb/certs /
   3 /
   4 error: unpacking of archive failed on file /var/lib/awx/venv/tower/lib/python2.7/site-packages/netaddr/eui/oui.idx;5a097bc0: cpio: write
   5 error: ansible-tower-server-3.1.5-3.el7at.x86_64: install failed
   6 /etc/httpd/conf.d /
   7 /

A subsequent "yum install ansible-tower-server" succeeded and seems to have resolved the issue.

Satoe, does that error mean anything to you?

Comment 3 Nick Carboni 2017-11-13 17:02:43 UTC
Could this have been a disk space issue at the time of install Luke?

Comment 4 Nick Carboni 2017-11-13 17:07:37 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1454884#c2

Comment 5 luke couzens 2017-11-14 09:31:07 UTC
Nick, 

your right this probably was a disk space issue, as I did forget to reconfigure the partitions prior to yum update. The second time I remembered and it worked correctly. This can probably be closed as not a bug unless Satoe still wants to take a look at that error.

Cheers,
Luke

Comment 6 Oleg Barenboim 2017-11-14 10:02:08 UTC
Satoe - per Luke's comment (https://bugzilla.redhat.com/show_bug.cgi?id=1512555#c5), would you please review.

Comment 7 Satoe Imaishi 2017-11-14 12:50:10 UTC
We're good to close.


Note You need to log in before you can comment on or make changes to this bug.