Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512552 - Nothing provides python2-twine
Summary: Nothing provides python2-twine
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-twine
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeremy Cline
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 13:52 UTC by Patrick Creech
Modified: 2017-11-29 19:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 19:53:18 UTC


Attachments (Terms of Use)

Description Patrick Creech 2017-11-13 13:52:23 UTC
It seems that with the move of twine from python-twine to twine in rawhide, python2 support has been removed.  This has broken the dependencies for a package I maintain in fedora's repos (pulp-python).


Providing a python2 version alongside the python3 one is something that is a viable strategy, and other python packages do this. (Ansible is one example that comes to mind).

Is there a way to get python2 support re-enabled for twine?

Comment 1 Jeremy Cline 2017-11-13 15:09:27 UTC
Hello,

This change was intended, see https://bugzilla.redhat.com/show_bug.cgi?id=1507815 for details. My recommendation is to use pkginfo rather than twine since twine is not intended to be a library.

Comment 2 Patrick Creech 2017-11-13 16:12:59 UTC
I am aware of the posted bug, as I came across it in my research as to why python2-twine disappeared, and agree with most of the changes in it.

I raised your suggestion to not use python2-twine as a dependency with the upstream project, but have been given no guidance as if or when this will be prioritized with them. 

Since there is no update available at this time for the package I maintain in fedora to not include python2-twine, and it does not support compilation as a python3 package, my only path to resolution is for something to provide python2-twine.  Other python command line applications in fedora provide both python2 and python3 run-times, so I would assume it is a valid thing to do here for twine as well, and would help reach a wider audience.

It would be appreciated if python2 support could be re-instated, at least until such time as this fix could be implemented upstream and propagated to fedora's packages either via update or back-port.

Comment 3 Jeremy Cline 2017-11-14 20:02:19 UTC
I can look at building a python2-twine package again that doesn't provide any binaries. However, I would ask that before I take the time to do that, please seriously consider not importing twine anymore. I looked at its usage in Pulp and it would be trivial to vendor the two modules you're using as a short-term solution.

That would be in your best interest, in any case, since there's nothing stopping twine from completely refactoring those modules at any time without changing the CLI and I'm not going to watch its internal APIs when I make updates. That means that your package could break at any time, even in stable releases. This change broke rawhide alone and you have plenty of time before rawhide branches and turns into F28 to fix this in upstream and backport it.

Comment 4 Patrick Creech 2017-11-14 20:57:20 UTC
Thank you!

I am not an active developer on the upstream project, so I have no influence over it's priorities or direction.  My only capacity in the project is that of a release engineer.

I will pass along your latest round of concerns to the upstream project and hope they will prioritize this for inclusion before the release of Fedora 28.  

I appreciate your advice, and thanks again for considering this.

Comment 5 Jeremy Cline 2017-11-29 19:53:18 UTC
Fixed in python-twine-1.9.1-4.fc28.


Note You need to log in before you can comment on or make changes to this bug.