Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512548 - yum ignores Requires statement in a spec file
Summary: yum ignores Requires statement in a spec file
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum
Version: 7.4
Hardware: Unspecified
OS: Unspecified
Target Milestone: rc
: ---
Assignee: Valentina Mukhamedzhanova
QA Contact: BaseOS QE Security Team
Depends On:
TreeView+ depends on / blocked
Reported: 2017-11-13 13:31 UTC by Michal Ruprich
Modified: 2017-11-13 14:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-11-13 14:08:05 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Michal Ruprich 2017-11-13 13:31:39 UTC
Description of problem:
I have added Requires statement in a spec file of tcpdump like this:

Requires: libpcap >= 1.5.3-10

Now after rebuilding tcpdump I tried to install it on RHEL-7.4 where the libpcap-1.5.3-10 is not available yet (should be available in 7.5) and I was expecting the install procedure to fail with an error. But even though yum printed message 

--> Processing Dependency: libpcap >= 1.5.3-10 for package: 14:tcpdump-4.9.2-2.el7.x86_64

it eventually tried to install lower version:

 tcpdump     x86_64     14:4.9.2-2.el7      /tcpdump-4.9.2-2.el7.x86_64    1.0 M
Installing for dependencies:
 libpcap     x86_64     14:1.5.3-9.el7      rhel     138 k

In my opinion this should not happen and the install process should end with an error.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try to install tcpdump from this scratch build on RHEL-7.4 machine

Actual results:
yum tries to install lower version(libpcap-1.5.3-9) than the one stated in Requires tag (libpcap-1.5.3-10)

Expected results:
yum should end with an error

Additional info:

Comment 2 Michal Ruprich 2017-11-13 14:08:05 UTC
Ok, mistake found between the screen and a chair. I forgot that libpcap has an epoch set so the version in Requires was always lower than the one available. Sorry about that.

Note You need to log in before you can comment on or make changes to this bug.