Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512532 - [RFE] Improve geo-replication log file naming for better readability
Summary: [RFE] Improve geo-replication log file naming for better readability
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1512535
TreeView+ depends on / blocked
 
Reported: 2017-11-13 12:53 UTC by Bipin Kunal
Modified: 2018-08-29 03:35 UTC (History)
9 users (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: Enhancement
Doc Text:
Clone Of: 1468972
: 1512535 (view as bug list)
Environment:
Last Closed: 2018-08-29 03:35:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Bipin Kunal 2017-11-13 12:53:24 UTC
+++ This bug was initially created as a clone of Bug #1468972 +++

Description of problem: 
Geo-replication log file naming should even be improved. It lacks filename readability. With current log file naming it is very difficult to relate it to what that log file is for.

Comment 1 Bipin Kunal 2017-11-13 13:07:27 UTC
Github tracker : https://github.com/gluster/glusterfs/issues/356

Comment 2 Aravinda VK 2017-11-14 06:10:44 UTC
This will be fixed as part of major refactor patch for Geo-rep. As per commit message log file name changes are

https://review.gluster.org/#/c/18257/

Both Master and Slave nodes will have subdir for session in the format 
"<mastervol>_<primary_slave_host>_<slavevol>

  - $GLUSTER_LOGDIR/geo-replication/<mastervol>_<primary_slave_host>_<slavevol>
  - $GLUSTER_LOGDIR/geo-replication-slaves/<mastervol>_<primary_slave_host>_<slavevol>

Log file paths renamed since session info is available with directory name itself.

  $LOG_DIR_MASTER/
    - gsyncd.log - Gsyncd, Worker monitor logs 
    - mnt-<brick-path>.log - Aux mount logs, mounted by each worker 
    - changes-<brick-path>.log - Changelog related logs(One per brick)

  $LOG_DIR_SLAVE/ 
    - gsyncd.log - Slave Gsyncd logs 
    - mnt-<master-node>-<master-brick-path>.log - Aux mount logs, mounted for each connection from master-node:master-brick 
    - mnt-mbr-<master-node>-<master-brick-path>.log - Same as above, but mountbroker setup

Comment 3 Amar Tumballi 2018-08-29 03:35:10 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.