Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512473 - The Init:Error pod should not be "Pod Initializing" sandglass on pod page
Summary: The Init:Error pod should not be "Pod Initializing" sandglass on pod page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.9.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 10:20 UTC by Xingxing Xia
Modified: 2018-03-28 14:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The web console's pod status filter had not been updated to account for init container status after init containers were added to the platform. Consequence: As a result, the web console's pod status filter did not display init status, including and init status of error. Fix: The pod status filter has been updated to display init status. Result: If a pod has an Init:Error status, the pod status filter now outputs "Init Error" instead of "Pod Initializing".
Clone Of:
Environment:
Last Closed: 2018-03-28 14:12:08 UTC


Attachments (Terms of Use)
Pod Initializing (deleted)
2017-11-13 10:20 UTC, Xingxing Xia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 14:12:37 UTC

Description Xingxing Xia 2017-11-13 10:20:14 UTC
Created attachment 1351497 [details]
Pod Initializing

Description of problem:
The Init:Error pod should not be "Pod Initializing" sandglass on pod page

Version-Release number of selected component (if applicable):
v3.7.7

How reproducible:
Always

Steps to Reproduce:
1. Make a pod whose status will be Init:Error
E.g. ordering Perl image on home page with invalid git repo, the build pod will be Init:Error
$ oc get build
NAME      TYPE      FROM         STATUS                       STARTED         DURATION
perl-1    Source    Git@master   Failed (FetchSourceFailed)   5 minutes ago   3s
$ oc get pod
NAME            READY     STATUS       RESTARTS   AGE
perl-1-build    0/1       Init:Error   0          2m

2. Check _pod_ "perl-1-build" status/icon on pods list page and pod page

Actual results:
2. It shows "Pod Initializing" sandglass, making a wrong feeling the pod is still initializing

Expected results:
2. Should show error status/icon

Additional info:

Comment 3 Robb Hamilton 2018-01-26 19:26:22 UTC
PR to resolve: https://github.com/openshift/origin-web-console/pull/2676

Comment 5 Xingxing Xia 2018-02-05 06:52:39 UTC
Checked in OCP v3.9.0-0.36.0, now the Init:Error pod is displayed correctly "X Init Error" in pods list page and pod page

Comment 8 errata-xmlrpc 2018-03-28 14:12:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489


Note You need to log in before you can comment on or make changes to this bug.