Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512455 - glustereventsd hardcodes working-directory
Summary: glustereventsd hardcodes working-directory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: eventsapi
Version: mainline
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 09:41 UTC by Vishal Pandey
Modified: 2018-03-15 11:20 UTC (History)
4 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1494526
Environment:
Last Closed: 2018-03-15 11:20:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Debian BTS 876344 None None None 2017-11-13 09:41:16 UTC

Description Vishal Pandey 2017-11-13 09:41:17 UTC
+++ This bug was initially created as a clone of Bug #1494526 +++

Hello,

in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876344 reports:

The glustereventd daemon hardcodes several paths (in eventsapiconf.py),
among them the glusterd working-directory to /var/lib/gulsterd. This
breaks badly when you have configured glusterd to use a different
working directory with something like:

,---
volume management
  type mgmt/glusterd
  option working-directory /some/other/path
  …
end-volume
`---

--- Additional comment from Worker Ant on 2017-11-13 04:25:09 EST ---

REVIEW: https://review.gluster.org/18726 (Events APIs:glustereventsd hardcodes working-directory) posted (#1) for review on master by Vishal Pandey

Comment 1 Worker Ant 2017-11-13 09:44:22 UTC
REVIEW: https://review.gluster.org/18726 (Events APIs:glustereventsd hardcodes working-directory) posted (#2) for review on master by Vishal Pandey

Comment 2 Worker Ant 2017-11-14 09:09:33 UTC
REVIEW: https://review.gluster.org/18761 (Events APIs:glustereventsd hardcodes working-directory) posted (#1) for review on master by Vishal Pandey

Comment 3 Worker Ant 2017-11-15 09:57:32 UTC
COMMIT: https://review.gluster.org/18761 committed in master by \"Vishal Pandey\" <vpandey@redhat.com> with a commit message- eventsapi: glustereventsd hardcodes working-directory

Issue:
Glusterevents daemon hardcodes glusterd working directory
 even though it can be changed later in .vol file
 which causes breaks in the code.

Fix: Use python subprocess module to get the working directory
of gluster daemon in eventsapiconf.py.in.

Change-Id: I5e92185604f8c8aeb77dabdc00f9ea0f8e92c88d
BUG: 1512455
Signed-off-by: Vishal Pandey <vishpandey2014@gmail.com>

Comment 4 Shyamsundar 2018-03-15 11:20:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.