Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512448 - improve g-c-c display layout user experience
Summary: improve g-c-c display layout user experience
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Matthias Clasen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1481395 1516404
TreeView+ depends on / blocked
 
Reported: 2017-11-13 09:25 UTC by Tomas Pelka
Modified: 2018-05-17 14:39 UTC (History)
5 users (show)

Fixed In Version: control-center-3.26.2-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1516404 (view as bug list)
Environment:
Last Closed: 2018-04-10 13:07:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:08:27 UTC
GNOME Bugzilla 789711 None None None 2017-11-15 14:34:47 UTC

Description Tomas Pelka 2017-11-13 09:25:18 UTC
Description of problem:
control-center can't save display layout configuration when fractional scaling is enabled.

My particular config:
1x full HD monitor
1x QHD monitor with fractional scaling 125%
laptop lid closed, build in display off

Version-Release number of selected component (if applicable):
control-center-3.26.2-1.el7
mutter-3.26.2-3.el7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
(gnome-control-center:8374): display-cc-panel-WARNING **: Config not applicable: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Logical monitors not adjecent

Expected results:


Additional info:

Comment 16 errata-xmlrpc 2018-04-10 13:07:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.