Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512446 - latest spacewalk-schema and upgraded satellite-schema are different
Summary: latest spacewalk-schema and upgraded satellite-schema are different
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiří Dostál
QA Contact: Ales Dujicek
URL:
Whiteboard:
Depends On:
Blocks: sat58-errata
TreeView+ depends on / blocked
 
Reported: 2017-11-13 09:24 UTC by Ales Dujicek
Modified: 2018-03-06 15:46 UTC (History)
3 users (show)

Fixed In Version: satellite-schema-5.8.0.41-1-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 15:46:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0393 normal SHIPPED_LIVE Red Hat Satellite 5.8.0 bug fix update 2018-03-06 20:47:01 UTC

Description Ales Dujicek 2017-11-13 09:24:36 UTC
Description of problem:

we removed nonlinux entitlement from 5.8 schema by upgrade script (bz1479337 and bz1466493)

but it is still in
./satellite/schema-override/data/common/rhnOrgEntitlementType.sql
./satellite/schema-override/data/common/rhnServerGroupType.sql

so if you install satellite with the latest schema package available, you will have nonlinux in database



Version-Release number of selected component (if applicable):
satellite-schema 5.8.0.37-1.el6sat

How reproducible:
always

Steps to Reproduce:
1. install Sat 5.8 with latest schema packages available

Actual results:
Data in [RHNORGENTITLEMENTTYPE] for [rhnsat@//GUEST:1522/RHNSAT.WORLD] and [user_rJ9GS6@//GUEST:1522/RHNSAT.WORLD]
select LABEL, NAME from RHNORGENTITLEMENTTYPE order by LABEL, NAME
> rhn_nonlinux Red Hat Network Non-Linux
Data in [RHNSERVERGROUPTYPE] for [rhnsat@//GUEST:1522/RHNSAT.WORLD] and [user_rJ9GS6@//GUEST:1522/RHNSAT.WORLD]
select IS_BASE, LABEL, NAME, PERMANENT from RHNSERVERGROUPTYPE order by IS_BASE, LABEL, NAME, PERMANENT
> Y nonlinux_entitled Non-Linux Entitled Servers N

Expected results:
no difference in schema

Comment 1 Jiří Dostál 2017-11-13 13:49:04 UTC
Created attachment 1351575 [details]
SAT5.8 patch

I'm enclosing a patch that resolves this issue.

Comment 9 errata-xmlrpc 2018-03-06 15:46:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0393


Note You need to log in before you can comment on or make changes to this bug.