Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512415 - [Doc]: Upgrade of 2.4 to 3.0 require following doc updates
Summary: [Doc]: Upgrade of 2.4 to 3.0 require following doc updates
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 3.0
Assignee: Bara Ancincova
QA Contact: Ramakrishnan Periyasamy
URL:
Whiteboard:
: 1512581 (view as bug list)
Depends On:
Blocks: 1496210
TreeView+ depends on / blocked
 
Reported: 2017-11-13 07:33 UTC by Ramakrishnan Periyasamy
Modified: 2018-05-23 16:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-26 03:41:47 UTC


Attachments (Terms of Use)

Description Ramakrishnan Periyasamy 2017-11-13 07:33:44 UTC
Description of problem:
RGW Upgrade of 2.4 to 3.0 failed for "radosgw_interface" param.

In 2.4 we never used to specify "radosgw_interface" but in 3.0 ceph-ansible expects "radosgw_interface" param because of this ceph-ansible failed.

For Installing cluster this change is added in "Table 3.1. General Ansible Settings" which needs to be added in upgrade part of the document also.

==========================================
Ansible failure during upgrade:
TASK [ceph-common : make sure monitor_interface, monitor_address or monitor_address_block is defined] ***
task path: /usr/share/ceph-ansible/roles/ceph-common/tasks/checks/check_mandatory_vars.yml:67
skipping: [magna006] => {
    "changed": false,
    "skip_reason": "Conditional result was False",
    "skipped": true
}

TASK [ceph-common : make sure radosgw_interface, radosgw_address or radosgw_address_block is defined] ***
task path: /usr/share/ceph-ansible/roles/ceph-common/tasks/checks/check_mandatory_vars.yml:76
fatal: [magna006]: FAILED! => {
    "changed": false,
    "failed": true,
    "msg": "you must set radosgw_interface, radosgw_address or radosgw_address_block"
}
===========================================

Version-Release number of selected component (if applicable):
NA

How reproducible:
NA

Steps to Reproduce:
NA

Actual results:
NA

Expected results:
NA

Additional info:
NA

Comment 3 Ramakrishnan Periyasamy 2017-11-13 11:06:23 UTC
There is one more update required in upgrade doc.

"subscription-manager repos --enable=rhel-7-server-extras-rpms" needs to be enabled.

Comment 4 Ramakrishnan Periyasamy 2017-11-13 15:27:09 UTC
These changes needs to be addressed in upgrade of cluster from 2.4 to 3.0

1. "subscription-manager repos --enable=rhel-7-server-extras-rpms" repo needs to be enabled before upgrading "ceph-ansible" (in pre-requisite section)

2. This bug is having a dependency on bz:1512581 since there is a bit of confusion in upgrade process.

As per our existing upgrade doc if we need to proceed the upgrade for rgw then we need to add "radosgw_interface: interface" to existing all.yml file before proceeding to step 4, if we do this then we can avoid the rgw issue mentioned in bug description part (which i tried and it worked).

3. User should be careful while executing step 5 which may lead overwrite of old custom param's updated by them for their environment.

Comment 10 Ramakrishnan Periyasamy 2017-11-14 10:07:57 UTC
Thanks for the quick update.

RHEL and Ubuntu documents look good, moving this bug to verified state.

Comment 16 Ken Dreyer (Red Hat) 2018-05-23 16:26:55 UTC
*** Bug 1512581 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.