Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512383 - Builds fail on ppc64le for no reason
Summary: Builds fail on ppc64le for no reason
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-13 05:26 UTC by wibrown@redhat.com
Modified: 2017-11-21 10:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 10:12:55 UTC


Attachments (Terms of Use)

Description wibrown@redhat.com 2017-11-13 05:26:18 UTC
Description of problem:

PPC64le fails with no error:

Mock Version: 1.4.4
Mock Version: 1.4.4
Mock Version: 1.4.4
ENTER ['do'](['bash', '--login', '-c', '/usr/bin/rpmbuild -bs --target ppc64le --nodeps /builddir/build/SPECS/389-ds-base.spec'], chrootPath='/var/lib/mock/661172-epel-7-ppc64le-1510550316.628899/root'env={'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'en_US.UTF-8'}shell=Falselogger=<mockbuild.trace_decorator.getLog object at 0x3fffb068c898>timeout=0uid=1001gid=135user='mockbuild'nspawn_args=[]printOutput=True)
ENTER ['do'](['bash', '--login', '-c', '/usr/bin/rpmbuild -bs --target ppc64le --nodeps /builddir/build/SPECS/389-ds-base.spec'], chrootPath='/var/lib/mock/661172-epel-7-ppc64le-1510550316.628899/root'env={'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'en_US.UTF-8'}shell=Falselogger=<mockbuild.trace_decorator.getLog object at 0x3fffb068c898>timeout=0uid=1001gid=135user='mockbuild'nspawn_args=[]printOutput=True)
Executing command: ['bash', '--login', '-c', '/usr/bin/rpmbuild -bs --target ppc64le --nodeps /builddir/build/SPECS/389-ds-base.spec'] with env {'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'en_US.UTF-8'} and shell False
Executing command: ['bash', '--login', '-c', '/usr/bin/rpmbuild -bs --target ppc64le --nodeps /builddir/build/SPECS/389-ds-base.spec'] with env {'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'en_US.UTF-8'} and shell False
warning: Could not canonicalize hostname: copr-builder-919751176.novalocal
warning: Could not canonicalize hostname: copr-builder-919751176.novalocal
Building target platforms: ppc64le
Building target platforms: ppc64le
Building for target ppc64le
Building for target ppc64le
Wrote: /builddir/build/SRPMS/389-ds-base-1.4.0.2-20171113git220dd3c4c.el7.centos.src.rpm
Wrote: /builddir/build/SRPMS/389-ds-base-1.4.0.2-20171113git220dd3c4c.el7.centos.src.rpm
Child return code was: 0
Child return code was: 0


https://copr-be.cloud.fedoraproject.org/results/firstyear/ds/epel-7-ppc64le/00661172-389-ds-base/build.log.gz


How reproducible:
Always

Steps to Reproduce:
1. use copr and enable ppc64le epel
2. build a package
3. wait

Actual results:
Package always fails.

Expected results:
Package should build, just like on fedora ppc64le

Additional info:
There is no other copr support channel on the website listed, so a bz is the only way to report operational failures like this,

Comment 1 clime 2017-11-21 10:12:55 UTC
Hello, please take a look at https://copr-be.cloud.fedoraproject.org/results/firstyear/ds/epel-7-ppc64le/00661172-389-ds-base/builder-live.log. The reason is there...

> Error: No Package found for libasan

I think reporting the bug is the best for this canse but you can also join #fedora-buildsys on channel on Freenode.


Note You need to log in before you can comment on or make changes to this bug.