Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512303 - Online button not working
Summary: Online button not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: guitarix
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brendan Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-12 14:36 UTC by Bruno Vernay
Modified: 2018-01-05 15:56 UTC (History)
3 users (show)

Fixed In Version: guitarix-0.36.1-1.fc27 guitarix-0.36.1-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-05 13:34:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1375815 None CLOSED guitarix must not depend on webkitgtk 2018-04-13 23:03:20 UTC

Description Bruno Vernay 2017-11-12 14:36:24 UTC
Description of problem:
The online button is not activated, not effect, no explanations.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch guitarix
2. clic on "Preset selection"
3. clic on "online "

Actual results:
No results

Expected results:
Should give access to online presets.

Additional info:
Maybe it is what WebKitGTK was used for and now it is removed for security reasons??

Comment 1 Fedora Update System 2017-12-27 17:51:35 UTC
guitarix-0.36.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fe746ed79f

Comment 2 Fedora Update System 2017-12-27 17:51:43 UTC
guitarix-0.36.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-feb82b9444

Comment 3 Fedora Update System 2017-12-27 22:38:15 UTC
guitarix-0.36.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-feb82b9444

Comment 4 Fedora Update System 2017-12-27 23:11:14 UTC
guitarix-0.36.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fe746ed79f

Comment 5 Bruno Vernay 2017-12-28 21:31:05 UTC
Problem does persist.
I get a "segmentation fault (core dumped)" when I click on the "Online"button.
See bug 1529597 

 Using:
guitarix.x86_64 0.36.1-1.fc27   
ladspa-guitarix-plugins.x86_64 0.36.1-1.fc27

Comment 6 Brendan Jones 2017-12-28 22:52:08 UTC
Well, I think this is a different bug. This issue relates to webkitgtk not being available. I cannot reproduce on my machine. I will try on another window manager

Comment 7 Fedora Update System 2018-01-05 13:34:43 UTC
guitarix-0.36.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-01-05 15:56:11 UTC
guitarix-0.36.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.