Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512264 - After attempting to remove a Containers Provider a Quadicon will indicate Provider's paused state [NEEDINFO]
Summary: After attempting to remove a Containers Provider a Quadicon will indicate Pro...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: GA
: cfme-future
Assignee: James Wong
QA Contact: Pavel Zagalsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-12 09:32 UTC by Pavel Zagalsky
Modified: 2017-12-05 15:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-15 19:23:08 UTC
Category: ---
Cloudforms Team: Container Management
gblomqui: needinfo? (pzagalsk)
jwong: needinfo? (hkataria)


Attachments (Terms of Use)
ProviderRemoval1 (deleted)
2017-11-12 09:32 UTC, Pavel Zagalsky
no flags Details
ProviderRemoval2 (deleted)
2017-11-12 09:32 UTC, Pavel Zagalsky
no flags Details
ProviderRemoval3 (deleted)
2017-11-12 09:33 UTC, Pavel Zagalsky
no flags Details

Description Pavel Zagalsky 2017-11-12 09:32:29 UTC
Created attachment 1351086 [details]
ProviderRemoval1

Description of problem:
After the user tries to delete a Containers Provider a Quadicon that appears will show for a few moments that that the Containers Provider is actually in a paused state instead of deleted

Version-Release number of selected component (if applicable):
5.9.0.9

How reproducible:
Always

Steps to Reproduce:
1. Add a Containers Provider
2. Try to remove it by selecting "Remove Containers Providers from Inventory"
3. Refresh the screen

Actual results:
The user will see a Quadicon that shows that the Containers Provider is in paused state.
The user also can press on the Quadicon and enter an dashboard menu 
Further refreshes will show that the Provider was deleted

Expected results:
The user should not see that Quadicon at all

Additional info:
Screenshots attached

Comment 2 Pavel Zagalsky 2017-11-12 09:32:58 UTC
Created attachment 1351087 [details]
ProviderRemoval2

Comment 3 Pavel Zagalsky 2017-11-12 09:33:41 UTC
Created attachment 1351099 [details]
ProviderRemoval3

Comment 4 Greg Blomquist 2017-11-14 11:06:13 UTC
Pavel, do you know if this happens with any provider type or only with a Containers provider?

Comment 5 Pavel Zagalsky 2017-11-14 11:13:57 UTC
Greg, I don't really work with other providers because I'm in the Containers Management team. Maybe someone from the relevant teams can chime in?

Comment 7 Greg Blomquist 2017-11-14 16:59:46 UTC
After talking to some of the developers, the "Pause Provider" in the quad icon is actually a "feature".  But, I'm a little worried about the 500 error in the third attachment.

Pavel, what action were you doing that produced that 500 error in the third attachment?

Comment 8 James Wong 2017-11-15 17:52:30 UTC
Got some help from Pavel and reproduced the 500 error.

Steps:
1. delete the provider
2. the provider becomes 'paused' state
3. click this provider to enter it's summary page (or dashboard page)
4. do nothing
5. after a while, the 500 error will pop up

The 500 error is understandable because the deleting of this provider is completed and it is removed from database.

It seems like UI would constantly querying for this provider even if user doesn't attempt any action.

Harpreet, can you comment on that?

In any case, this seems an edge case.
Dave, do you think the priority/severity can be re-assessed?

Comment 9 Greg Blomquist 2017-11-15 18:21:36 UTC
James,

when you say "the 500 error will pop up", do you mean that literally?  As in, you just get a popup with the 500 error?

Or, does it show up in a particular place?

Comment 12 Greg Blomquist 2017-11-15 19:23:08 UTC
The original issue is "works as designed" (Container provider "pauses" when deleted).

The follow-on issue is actually a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1506114.  


I'm closing this as NotABug to reflect the original bug summary is working as designed.


Note You need to log in before you can comment on or make changes to this bug.