Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512247 - cloud-init fails to configure the network after upgrade.
Summary: cloud-init fails to configure the network after upgrade.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cloud-init
Version: 7.4
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: rc
: 7.4
Assignee: Ryan McCabe
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
: 1514195 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-12 01:41 UTC by Siggy Sigwald
Modified: 2018-04-10 14:08 UTC (History)
18 users (show)

Fixed In Version: cloud-init-0.7.9-23.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 14:08:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3293121 None None None 2017-12-18 12:05:29 UTC
Red Hat Product Errata RHEA-2018:0806 None None None 2018-04-10 14:08:33 UTC

Description Siggy Sigwald 2017-11-12 01:41:43 UTC
Description of problem:
After upgrading from RHEL 7.3 to RHEL 7.4 cloud-init fails to bring up all the network interfaces.

Version-Release number of selected component (if applicable):

cloud-init-0.7.9-9.el7_4.1.x86_64

How reproducible:
It happens after every upgrade.

Nov 11 14:40:35 hostname NetworkManager[1301]: <info>  [1510436435.9442] manager: (enp13s0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/5)
Nov 11 14:40:36 hostname kernel: device enp13s0 entered promiscuous mode
Nov 11 14:40:36 hostname NetworkManager[1301]: <info>  [1510436436.0337] device (enp13s0): enslaved to non-master-type device ovs-system; ignoring
Nov 11 14:40:36 hostname kernel: enic 0000:0d:00.0 enp13s0: vxlan: only IPv4 offload supported
Nov 11 14:40:36 hostname kernel: enic 0000:0d:00.0 enp13s0: vxlan: failed to offload vxlan udp port 4789, IP protocol 10
Nov 11 14:40:36 hostname kernel: enic 0000:0d:00.0 enp13s0: vxlan: failed to offload vxlan udp port 4789, IP protocol 2
Nov 11 14:40:52 hostname kernel: enic 0000:0d:00.0 enp13s0: Link UP
Nov 11 14:40:52 hostname kernel: IPv6: ADDRCONF(NETDEV_UP): enp13s0: link is not ready
Nov 11 14:40:52 hostname kernel: IPv6: ADDRCONF(NETDEV_CHANGE): enp13s0: link becomes ready
Nov 11 14:40:52 hostname NetworkManager[1301]: <info>  [1510436452.9602] device (enp13s0): link connected
Nov 11 14:40:52 hostname NetworkManager[1301]: <info>  [1510436452.9603] device (enp13s0): enslaved to non-master-type device ovs-system; ignoring
Nov 11 14:40:53 hostname ovs-vsctl: ovs|00001|vsctl|INFO|Called as ovs-vsctl -t 10 -- --if-exists del-port br-ex enp13s0 -- add-port br-ex enp13s0
Nov 11 14:40:53 hostname network: Bringing up interface enp13s0:  [  OK  ]
Nov 11 14:40:56 hostname ntpd[1294]: Listen normally on 15 enp13s0 fe80::225:b5ff:fe3c:be29 UDP 123
Nov 11 14:41:04 hostname cloud-init: ci-info: |     enp13s0:     |  True |       .       |       .       |   .   | 00:25:b5:3c:be:29 |
Nov 11 14:41:04 hostname cloud-init: ci-info: |     enp13s0:     |  True |       .       |       .       |   d   | 00:25:b5:3c:be:29 |
Nov 11 14:41:05 hostname NetworkManager[1301]: <info>  [1510436464.9965] device (enp13s0): enslaved to non-master-type device ovs-system; ignoring
Nov 11 14:41:05 hostname cloud-init: 2017-11-11 14:41:05,000 - stages.py[WARNING]: Failed to rename devices: [unknown] Error performing rename('enp13s0', 'br-ex') for 00:25:b5:3c:be:29, br-ex: Unexpected error while running command.
Nov 11 14:41:05 hostname cloud-init: Command: ['ip', 'link', 'set', 'enp13s0', 'name', 'br-ex']
Nov 11 14:41:06 hostname ntpd[1294]: Deleting interface #15 enp13s0, fe80::225:b5ff:fe3c:be29#123, interface stats: received=0, sent=0, dropped=0, active_time=10 secs

Comment 36 Ryan McCabe 2018-01-16 15:40:07 UTC
*** Bug 1514195 has been marked as a duplicate of this bug. ***

Comment 49 errata-xmlrpc 2018-04-10 14:08:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0806


Note You need to log in before you can comment on or make changes to this bug.