Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512200 - update to f27 would downgrade borgbackup
Summary: update to f27 would downgrade borgbackup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: borgbackup
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Pereto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-11 13:19 UTC by Neal Becker
Modified: 2017-11-21 23:30 UTC (History)
2 users (show)

Fixed In Version: borgbackup-1.1.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 23:30:42 UTC


Attachments (Terms of Use)

Description Neal Becker 2017-11-11 13:19:49 UTC
Description of problem:
f27 has 1.0.11-4.fc27
while f26 has
rpm -q borgbackup
borgbackup-1.1.0-1.fc26.x86_64


I don't know if this would break my backups which have already been run using f26 on client and server

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Benjamin Pereto 2017-11-11 14:12:30 UTC
Hi,

sorry for this issue, I forgot to push updates to f27 since it was branched from rawhide.

I submit immediately updates.

Comment 2 Benjamin Pereto 2017-11-11 14:51:41 UTC
as far as I tested locally, it should not break.

- borgbackup-1.1.0-1.fc26.x86_64
borg init test -e repokey
borg create test::test /home/
borg create test::test2 /etc
sudo dnf downgrade borgbackup
- borgbackup-1.0.10-1.fc26.x86_64
borg list test
borg create test::test3 /etc
borg create test::test4 /usr/bin
borg extract test::test2 etc/test.conf

works for me.

Comment 3 Fedora Update System 2017-11-11 14:53:47 UTC
borgbackup-1.1.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4ff3ac2307

Comment 4 Fedora Update System 2017-11-14 10:56:41 UTC
borgbackup-1.1.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4ff3ac2307

Comment 5 Fedora Update System 2017-11-21 23:30:42 UTC
borgbackup-1.1.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.