Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512163 - patch: octave macros: package deps not loaded for checks
Summary: patch: octave macros: package deps not loaded for checks
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-11 03:52 UTC by Colin Macdonald
Modified: 2018-07-15 04:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-15 04:10:36 UTC


Attachments (Terms of Use)

Description Colin Macdonald 2017-11-11 03:52:36 UTC
Suppose a octave-pkg1 depends on octave-pkg2.  Specifically, suppose the tests of -pkg1 depend on having -pkg2 loaded.

I think the current "%octave_pkg_check" doesn't load dependencies.  It does:

> pkg("install","-nodeps","-verbose",...

Some good reason to have that "-nodeps"?  I haven't tried without in practice but will do when I get a chance...

For a practical example of why this matters, see my PR to octave-optim which tries to enable tests.

Comment 1 Colin Macdonald 2017-11-11 16:03:28 UTC
I've tried without "-nodeps".  I also had to stop overwriting "global_list".

I have tested the result on building my branch of octave-optim (with checks enabled).  Even if I have it previously installed on my system, the version in "local_list" is preferred and the tests are run correctly.

I've prepared a pull request for the macro change: https://src.fedoraproject.org/rpms/octave/pull-request/2

Comment 2 Fedora End Of Life 2018-02-20 15:25:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 3 Colin Macdonald 2018-06-01 05:37:28 UTC
I merged master to my merge request


Note You need to log in before you can comment on or make changes to this bug.