Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512125 - Wrong list of profile children options for some configurations
Summary: Wrong list of profile children options for some configurations
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.3.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: CR01
: One-off release
Assignee: Simeon Pinder
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On: 1478056
Blocks: 1387292
TreeView+ depends on / blocked
 
Reported: 2017-11-10 22:16 UTC by Larry O'Leary
Modified: 2018-02-16 10:02 UTC (History)
4 users (show)

Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1439343
Environment:
Last Closed: 2018-02-16 10:02:28 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1439343 None None None Never
Red Hat Bugzilla 1478056 None None None Never

Internal Links: 1439343 1478056

Description Larry O'Leary 2017-11-10 22:16:50 UTC
+++ Fix is for EAP 6 as well. The work was done together with Bug #1439343 (EAP 7 variant) +++

Description of problem:
When running EAP on domain mode, some profile child configurations appear wrong, having more items than they should.
The options are being taken from all the profiles rather than the current profile. 

This confuses the user because he could think that all the elements there belong to the current profile.

All elements that have any 'option source' (on rhq-plugin.xml) with a type of a Profile children are likely affected even if they use the 'expressionScope="baseResource"'.

e.g.

<c:option-source target="resource" expressionScope="baseResource" expression="type='^Buffer Pool (Profile)$' plugin=&pluginName;"/>

or

<c:option-source target="resource" expressionScope="baseResource" expression="type='Buffer Pool' plugin=&pluginName;"/> 

This is because it will filter the resources up to the EAP and not the Profile.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start and inventory an EAP instance in domain mode
2. Go to Profiles -> default -> Connector -> jca and add (right click jca) a Workmanager children with the name 'default_workmanager'
3. Go to Profiles -> full-ha -> Connector -> jca and add (right click jca) a Workmanager children with the name 'full_ha_workmanager'
4. Go to the Configuration of Profiles -> full-ha -> Connector -> jca -> BootstrapContext (Profile)s -> default
5. Notice 'Workmanager' Property.

Actual results:
It contains the following options: 'default', 'default_workmanager' and 'full_ha_workmanager'.

Expected results:
It should only contain the following options: 'default' and 'full_ha_workmanager'.


Additional info:

This might also happen on EAP6

--- Additional comment from Josejulio Martínez on 2017-05-03 10:17:19 EDT ---

These fixes are for the core and the plugin (EAP6,7)



commit d7d28ebc3221bb0775ac17bc4d5a3b6002b5fef4
Merge: b66a2ce a698af3
Author: Michael Burman <yak@iki.fi>
Date:   Wed May 3 09:40:01 2017 +0300

    Merge pull request #303 from josejulio/bugs/1439343
    
    Bug 1439343 - Overload expression to accept a 'baseResource' type to …

commit a698af3a1dae932feb6a15e55d7458f91692a778
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Thu Apr 27 22:28:34 2017 -0500

    Using ProfileBaseResource instead of Profile;baseResource

commit 931816539a8da263ede0d890e51c91c080baf246
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Thu Apr 27 00:16:59 2017 -0500

    Adding several expressionScope=baseResource and using the new Profile;baseResource.plugin=...
    on jboss-as-7 plugin

commit fd76379afc41cdbad4ddb06bc02ab7bdd033690c
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Thu Apr 27 00:05:06 2017 -0500

    Adding several expressionScope=baseResource and using the new Profile;baseResource.plugin=... on io subsystem resources

commit 6d6fe7abfda5141b9440eafb778617a52a2aa04b
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Fri Apr 21 12:11:32 2017 -0500

    Use CriteriaQueryGenerator's bug to inject extra params on the expression query.

commit eb92f7dd8b36a1a5f10ca19d445ca62b06bf1b70
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Tue Apr 18 16:39:35 2017 -0500

    Fixed Profile children could have wrong option-sources

commit d573b5f879f6614ca5aaa5df31a8429c81de7420
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Thu Apr 6 13:04:27 2017 -0500

    Bug 1439343 - Overload expression to accept a 'baseResource' type to use instead
    of the topmost ancestor.


Note You need to log in before you can comment on or make changes to this bug.