Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512092 - radosgw segfault after running 'radosgw-admin data sync init'
Summary: radosgw segfault after running 'radosgw-admin data sync init'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.0
Assignee: Matt Benjamin (redhat)
QA Contact: Parikshith
URL:
Whiteboard:
: 1512258 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 20:07 UTC by Casey Bodley
Modified: 2018-01-05 21:15 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-12.2.1-40.el7cp Ubuntu: ceph_12.2.1-42redhat1xenial
Doc Type: No Doc Update
Doc Text:
.
Clone Of:
Environment:
Last Closed: 2017-12-05 23:50:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC
Ceph Project Bug Tracker 22083 None None None 2017-11-10 20:07:25 UTC

Description Casey Bodley 2017-11-10 20:07:26 UTC
Description of problem:

The 'radosgw-admin data sync init' command resets the data sync status to its initial state, but accidentally sets the num_shards to 0.

When radosgw's sync process next reads this status, the invalid value of num_shards leads to a segfault.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure multisite with two zones.
2. Create a bucket and upload some objects.
3. Wait for `radosgw-admin sync status` to catch up on the secondary zone.
4. Run `radosgw-admin data sync init` to reset the sync status.

Actual results:

radosgw segfaults:

656         return shards[shard_id]->append(entry);
(gdb) bt
#0  0x00005555560c7feb in RGWShardedOmapCRManager::append (this=0x555557373c40, entry=..., shard_id=107) at /src/rgw/rgw_cr_rados.h:656
#1  0x000055555610576c in RGWListBucketIndexesCR::operate (this=0x555557263000) at /src/rgw/rgw_data_sync.cc:773
#2  0x0000555555e5004d in RGWCoroutinesStack::operate (this=0x55555719f9c0, _env=0x7fffcb2a1cb0) at /src/rgw/rgw_coroutine.cc:195
#3  0x0000555555e5187f in RGWCoroutinesManager::run (this=0x555557058388, stacks=...) at /src/rgw/rgw_coroutine.cc:485
#4  0x0000555555e52ba7 in RGWCoroutinesManager::run (this=0x555557058388, op=0x555557015000) at /src/rgw/rgw_coroutine.cc:624
#5  0x00005555560f0513 in RGWRemoteDataLog::run_sync (this=0x555557058388, num_shards=128) at /src/rgw/rgw_data_sync.cc:1645
#6  0x0000555555f38522 in RGWDataSyncStatusManager::run (this=0x555557058330) at /src/rgw/rgw_data_sync.h:320
#7  0x0000555555f3a587 in RGWDataSyncProcessorThread::process (this=0x555557058300) at /src/rgw/rgw_rados.cc:3241
#8  0x0000555555edb7f8 in RGWRadosThread::Worker::entry (this=0x555556eba220) at /src/rgw/rgw_rados.cc:3049
#9  0x00007fffedf59639 in Thread::entry_wrapper (this=0x555556eba220) at /src/common/Thread.cc:79
#10 0x00007fffedf5956e in Thread::_entry_func (arg=0x555556eba220) at /src/common/Thread.cc:59
#11 0x00007ffff6b0c744 in start_thread (arg=0x7fffcb2a4700) at pthread_create.c:334
#12 0x00007fffe9f36aad in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109



Expected results:


Additional info:

Comment 3 Ken Dreyer (Red Hat) 2017-11-14 16:13:49 UTC
*** Bug 1512258 has been marked as a duplicate of this bug. ***

Comment 16 errata-xmlrpc 2017-12-05 23:50:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.