Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512074 - java.lang.OutOfMemoryError: Java heap space
Summary: java.lang.OutOfMemoryError: Java heap space
Keywords:
Status: CLOSED DUPLICATE of bug 1512073
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Michael Vorburger
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 19:02 UTC by Sai Sindhur Malleni
Modified: 2018-10-24 12:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-11-27 14:58:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight Bug NETVIRT-985 None None None 2017-11-10 19:04:40 UTC

Description Sai Sindhur Malleni 2017-11-10 19:02:22 UTC
Description of problem:
On running perf/scale tests on an OSP 12 cloud with 3 OpenStack controllers + 3 ODLs + 28 computes, by creating 100s of neutron resources and deleting them we see OOM on an ODL instance.  

Version-Release number of selected component (if applicable):
OSP12
Puddle: 2017-10-31.2
ODL RPM: opendaylight-6.2.0-3.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Run perf/scale tests using Browbeat+neutron and create large number of neutro nresources
2.
3.

Actual results:
one of the ODLs dies due to OOM

Expected results:
There should be no OOM

Additional info:
STDOUT of JVM when exiting
https://gist.github.com/smalleni/e9fab9985f3b44088e8490ce441fa221

Comment 1 Michael Vorburger 2017-11-27 14:58:43 UTC

*** This bug has been marked as a duplicate of bug 1512073 ***


Note You need to log in before you can comment on or make changes to this bug.