Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512026 - [Ansible Tower] Clicking on Tower Provider results in Infinite spinner or Error 500 Internal Server Error
Summary: [Ansible Tower] Clicking on Tower Provider results in Infinite spinner or Er...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.10.0
Assignee: Dan Clarizio
QA Contact: Kedar Kulkarni
URL:
Whiteboard:
: 1512503 1512599 (view as bug list)
Depends On:
Blocks: 1514172
TreeView+ depends on / blocked
 
Reported: 2017-11-10 17:11 UTC by Kedar Kulkarni
Modified: 2018-06-21 21:06 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1514172 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:06:02 UTC
Category: ---
Cloudforms Team: ---
kkulkarn: automate_bug-


Attachments (Terms of Use)
Screenshot (deleted)
2017-11-10 17:11 UTC, Kedar Kulkarni
no flags Details
Screenshot 2 (deleted)
2017-11-10 18:53 UTC, Kedar Kulkarni
no flags Details

Description Kedar Kulkarni 2017-11-10 17:11:25 UTC
Created attachment 1350603 [details]
Screenshot

Description of problem:
Clicking on Tower Provider results in Infinite spinner or  Error 500 Internal Server Error See screenshot attached

Version-Release number of selected component (if applicable):
5.9.0.8

How reproducible:
Believe 100%

Steps to Reproduce:
1.Automate->Ansible Tower -> Explorer
2.Add new Provider
3.Click on name of Provider in "Providers" or "Job Templates" accordion 

Actual results:
See screenshot, either that or Infinite Spinner

Expected results:
Should show provider details

Additional info:

Comment 2 Kedar Kulkarni 2017-11-10 18:53:56 UTC
Created attachment 1350619 [details]
Screenshot 2

Clicking on the provider on right hand side(in the table, not Accordion) also makes it throw 500 Error. See screenshot 2, it show "network" activity in browser console.

Comment 4 Harpreet Kataria 2017-11-13 14:34:38 UTC
*** Bug 1512503 has been marked as a duplicate of this bug. ***

Comment 5 Harpreet Kataria 2017-11-13 16:05:26 UTC
*** Bug 1512599 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.