Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511990 - Provide a s390x specific /etc/modprobe.d/kvm.conf
Summary: Provide a s390x specific /etc/modprobe.d/kvm.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-ma
Version: 7.5-Alt
Hardware: s390x
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: David Hildenbrand
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1517144
TreeView+ depends on / blocked
 
Reported: 2017-11-10 15:22 UTC by David Hildenbrand
Modified: 2018-04-10 14:58 UTC (History)
4 users (show)

Fixed In Version: qemu-kvm-ma-2.10.0-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517144 (view as bug list)
Environment:
Last Closed: 2018-04-10 14:55:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0831 None None None 2018-04-10 14:58:17 UTC

Description David Hildenbrand 2017-11-10 15:22:08 UTC
Description of problem:
kvm.conf is currently x86 specific

Steps to Reproduce:
1. cat kvm.conf

Actual results:

# Setting modprobe kvm_intel/kvm_amd nested = 1
# only enables Nested Virtualization until the next reboot or
# module reload. Uncomment the option applicable
# to your system below to enable the feature permanently.
#
# User changes in this file are preserved across upgrades.
#
# For Intel
#options kvm_intel nested=1
#
# For AMD
#options kvm_amd nested=1

Expected results:

# Setting modprobe kvm nested = 1
# only enables Nested Virtualization until the next reboot or
# module reload. Uncomment the option applicable
# to your system below to enable the feature permanently.
#
# User changes in this file are preserved across upgrades.
#
#options kvm nested=1

Comment 3 Miroslav Rezanina 2017-11-22 15:21:42 UTC
Fix included in qemu-kvm-ma-2.10.0-7.el7

Comment 5 Qunfang Zhang 2017-11-24 10:01:40 UTC
Reproduced on qemu-kvm-ma-2.10.0-6.el7.s390x: 

# cat /etc/modprobe.d/kvm.conf 
# Setting modprobe kvm_intel/kvm_amd nested = 1
# only enables Nested Virtualization until the next reboot or
# module reload. Uncomment the option applicable
# to your system below to enable the feature permanently.
#
# User changes in this file are preserved across upgrades.
#
# For Intel
#options kvm_intel nested=1
#
# For AMD
#options kvm_amd nested=1

Verified pass on qemu-kvm-ma-2.10.0-7.el7.s390x:

# cat /etc/modprobe.d/kvm.conf 
# Setting "modprobe kvm nested=1" only enables Nested Virtualization until
# the next reboot or module reload. Uncomment the option below to enable
# the feature permanently.
#
# User changes in this file are preserved across upgrades.
#
#options kvm nested=1

Setting to VERIFIED.

Comment 9 errata-xmlrpc 2018-04-10 14:55:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0831


Note You need to log in before you can comment on or make changes to this bug.