Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511924 - Rebase to upstream ovirt-guest-agent 1.0.14 for RHEV 4.2 (RHEL7)
Summary: Rebase to upstream ovirt-guest-agent 1.0.14 for RHEV 4.2 (RHEL7)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: 4.1.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Tomáš Golembiovský
QA Contact: Jiri Belka
URL:
Whiteboard:
: 1508399 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 12:41 UTC by Tomáš Golembiovský
Modified: 2017-12-11 14:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-11 14:45:00 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3407 normal SHIPPED_LIVE ovirt-guest-agent bug fix and enhancement update 2017-12-11 19:44:43 UTC

Description Tomáš Golembiovský 2017-11-10 12:41:41 UTC

Comment 2 Jiri Belka 2017-11-15 12:25:51 UTC
it seems default enabling ovirt-guest-agent is dropped with tuned* stuff from rpm scripts:

- comparison between 1.0.14.1 an 10.0.14.2

 /sbin/udevadm trigger --subsystem-match="memory"
 
 /bin/systemctl daemon-reload
-
-TUNED_ADM=/usr/sbin/tuned-adm
-TUNED_PROFILE=virtual-guest
-if ! /bin/systemctl status tuned.service > /dev/null 2>&1; then
-    /bin/systemctl start tuned.service
-fi
-if (! $TUNED_ADM active > /dev/null 2>&1 || $TUNED_ADM active | \
-        grep -q "balanced$") && $TUNED_ADM list | grep -q $TUNED_PROFILE; then
-    $TUNED_ADM profile $TUNED_PROFILE
-fi
-if [ $1 -eq 1 ] ; then
-    /bin/systemctl enable ovirt-guest-agent.service
-fi
 preuninstall scriptlet (using /bin/sh):
 if [ "$1" -eq 0 ]
 then

Comment 3 Tomáš Golembiovský 2017-11-23 14:10:11 UTC
*** Bug 1508399 has been marked as a duplicate of this bug. ***

Comment 4 Jiri Belka 2017-11-29 10:18:49 UTC
ok, 1.0.14-3

# rpm -qR ovirt-guest-agent-common | egrep "(^config|tuned)"
config(ovirt-guest-agent-common) = 1.0.14-3.el7ev

# systemctl status ovirt-guest-agent | egrep "^[[:blank:]]*(Loaded|Active):"
   Loaded: loaded (/usr/lib/systemd/system/ovirt-guest-agent.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2017-11-29 11:16:11 CET; 1min 47s ago

Comment 10 errata-xmlrpc 2017-12-11 14:45:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3407


Note You need to log in before you can comment on or make changes to this bug.