Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511901 - [Ceph-ansible][Ubuntu] Ansible is failing looking for loop devices when osd_auto_discovery is true [NEEDINFO]
Summary: [Ceph-ansible][Ubuntu] Ansible is failing looking for loop devices when osd_a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 3.0
Assignee: leseb
QA Contact: Pratik Surve
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 11:56 UTC by Pratik Surve
Modified: 2017-12-05 23:50 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.11-1.el7cp Ubuntu: ceph-ansible_3.0.11-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 23:50:29 UTC
edonnell: needinfo? (shan)
prsurve: needinfo? (shan)


Attachments (Terms of Use)
Contains all.yml,osd.yml,inventory and ansible logs (deleted)
2017-11-10 11:56 UTC, Pratik Surve
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Pratik Surve 2017-11-10 11:56:41 UTC
Created attachment 1350437 [details]
Contains all.yml,osd.yml,inventory and ansible logs

Description of problem:
ceph-ansible is looking for loop device on ubuntu for OSD and getting the failure



Version-Release number of selected component (if applicable):
1-ceph-ansible 3.0.9-2
2-Ubuntu 16.04.3 LTS

How reproducible:
always

Steps to Reproduce:
1.configure all.yml as per doc
2.in osd.yml set osd_auto_discovery: true and osd_scenerio: collocated


Actual results:
"stderr": "create_partition: refusing to create journal on /dev/loop0\ncreate_partition: journal size (5120M) is bigger than device (0M)\nceph-disk: Error: /dev/loop0 device size (0M) is not big enough for journal", 
    "stderr_lines": [
        "create_partition: refusing to create journal on /dev/loop0", 
        "create_partition: journal size (5120M) is bigger than device (0M)", 
        "ceph-disk: Error: /dev/loop0 device size (0M) is not big enough for journal"


Expected results:
Cluster installation must be successfull

Additional info: 

1.tries running ansible after removing loop devices with with OSError: [Errno 2] No such file or directory: '/dev/loop0'" 
2.running playbook on RHEL with creating loop devices playbook was successfull

Comment 5 Gregory Meno 2017-11-10 16:11:29 UTC
This bug is not-crucial for 3.0 imho -- moving to 3.1

Comment 7 leseb 2017-11-13 16:15:05 UTC
Fixed in 3.0.11

Comment 17 errata-xmlrpc 2017-12-05 23:50:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.