Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511897 - Possible Memory Leak in MetricsProcessor Worker
Summary: Possible Memory Leak in MetricsProcessor Worker
Keywords:
Status: CLOSED DUPLICATE of bug 1479339
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Performance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.9.0
Assignee: Nick LaMuro
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 11:36 UTC by Himanshu Roy
Modified: 2018-02-09 15:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-09 14:12:10 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Comment 5 Dave Johnson 2017-12-08 15:00:57 UTC
Himanshu, per comment 4, it sounds like this can be closed.  Can you confirm and please do so.

Comment 9 Nick LaMuro 2018-01-18 16:08:11 UTC
A possible fix has been proposed in this related BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=1535720


That is targeted for the MiqServer, and high confidence that it will fix the leak there.  Updates will probably happen there more regularly until we determine if there is a different leak in the MetricsProcessor Worker, and there is a high probability this was a leak across all workers.

Comment 10 Nick LaMuro 2018-01-19 23:56:06 UTC
The fix above has been backported here:

https://bugzilla.redhat.com/show_bug.cgi?id=1536658

We are going to do some testing ourselves to see if this is fixing the issue with the MetricsProcessor as well, and will update with those results.

Comment 11 Nick LaMuro 2018-02-01 22:46:36 UTC
Update:

We are relatively sure that this leak will be resolved with the patch provided in https://bugzilla.redhat.com/show_bug.cgi?id=1535720 (or the respective backported version), so this might already be fixed.

That said, we are doing some final long term comparisons with our test environments to confirm that the systems that had the patch applied and displayed no leak, will start leaking once the patch is removed.  We are confident this patch fixes the leak with MiqServer, but want to be confident in saying this is the same with the other workers as well, and that there isn't possibly another leak at play here.

Next update will be roughly in a week's time.

Comment 12 Nick LaMuro 2018-02-08 17:40:29 UTC
After testing on a pair of appliances for about a week, we are fairly confident that this has a substantial impact to the memory footprint of all the workers, including the MetricsProcessorWorker, as mentioned here.

Please retest with the changes in place, and if the issue persists, feel free to kick the ticket back so we can look into it further.

Comment 13 Satoe Imaishi 2018-02-09 14:12:10 UTC

*** This bug has been marked as a duplicate of bug 1479339 ***


Note You need to log in before you can comment on or make changes to this bug.