Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511890 - Possible Memory Leak in MiqGenericWorker
Summary: Possible Memory Leak in MiqGenericWorker
Keywords:
Status: CLOSED DUPLICATE of bug 1535720
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Performance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.9.0
Assignee: Keenan Brock
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 11:23 UTC by Himanshu Roy
Modified: 2018-02-23 14:59 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-23 13:44:28 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Comment 6 Keenan Brock 2018-01-19 18:29:54 UTC
A possible solution was posted to fix the MiqServer:

https://bugzilla.redhat.com/show_bug.cgi?id=1535720

After applying this locally, it has brought a lot of the memory instability under control, especially with the C&U Metrics Collector.

The jury is still out with the GenericWorker. So I'm diving into that at this time.

Comment 7 Keenan Brock 2018-02-07 13:44:17 UTC
Himanshu,

The patch that went in reduced most of the leaks I am seeing in the various workers.

Would you please retest with the latest and confirm you still see it?

Thanks

Comment 9 dmetzger 2018-02-23 13:44:28 UTC
The source of this issue was a leak in Ruby "require" which was found while investigating a leak in Miq Server and has been fixed under BZ 1535720

*** This bug has been marked as a duplicate of bug 1535720 ***


Note You need to log in before you can comment on or make changes to this bug.