Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511878 - lcgdm FTBFS with globus-gsi-credential 7.13 and later
Summary: lcgdm FTBFS with globus-gsi-credential 7.13 and later
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lcgdm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ricardo Rocha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 10:49 UTC by Mattias Ellert
Modified: 2017-11-12 15:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-12 15:40:34 UTC


Attachments (Terms of Use)
Patch that adapts the lcgdm code for the removed STACK macro (deleted)
2017-11-10 10:49 UTC, Mattias Ellert
no flags Details | Diff

Description Mattias Ellert 2017-11-10 10:49:16 UTC
Created attachment 1350413 [details]
Patch that adapts the lcgdm code for the removed STACK macro

Description of problem:

The STACK macro was removed in globus-gsi-credential 7.13.

Version-Release number of selected component (if applicable):

1.9.0-8.fc27
1.9.0-4.fc26
1.9.0-1.fc25
1.9.0-1.el7
1.9.0-1.el6

How reproducible:

Always.

Steps to Reproduce:
1. Build lcgdm using globus-gsi-credential 7.13 or later

Actual results:

Build fails due to use of STACK macro.

Expected results:

Successful build.

Additional info:

Patch attached.

Comment 1 Andrea 2017-11-12 15:40:34 UTC
thanks Mattias!
the patched version is building in rawhide


Note You need to log in before you can comment on or make changes to this bug.