Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511804 - GUI: Cannot launch GUI when the consumer is deleted at server side
Summary: GUI: Cannot launch GUI when the consumer is deleted at server side
Keywords:
Status: CLOSED DUPLICATE of bug 1510727
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
Depends On:
Blocks: 1444512
TreeView+ depends on / blocked
 
Reported: 2017-11-10 08:13 UTC by Shwetha Kallesh
Modified: 2017-11-16 15:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-16 15:28:51 UTC


Attachments (Terms of Use)

Description Shwetha Kallesh 2017-11-10 08:13:54 UTC
Description of problem:
GUI: Cannot launch GUI when the consumer is deleted at server side

Version-Release number of selected component (if applicable):
[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7


How reproducible:


Steps to Reproduce:
[root@dhcp35-121 ~]# subscription-manager register --serverurl F21-candlepin.usersys.redhat.com:8443/candlepin
Registering to: F21-candlepin.usersys.redhat.com:8443/candlepin
Username: admin
Password: 
Organization: admin
The system has been registered with ID: e19c21d2-55cd-4747-9abc-3476dae5a6d7
The registered system name is: dhcp35-121.lab.eng.blr.redhat.com

[root@dhcp35-121 ~]# curl -k -u admin:admin --request DELETE https://F21-candlepin.usersys.redhat.com:8443/candlepin/consumers/e19c21d2-55cd-4747-9abc-3476dae5a6d7[root@dhcp35-121 ~]# subscription-manager identity
Unit e19c21d2-55cd-4747-9abc-3476dae5a6d7 has been deleted

root@dhcp35-121 ~]# subscription-manager-gui
Unit e19c21d2-55cd-4747-9abc-3476dae5a6d7 has been deleted



Actual results:
Unit e19c21d2-55cd-4747-9abc-3476dae5a6d7 has been deleted

Expected results:
Should be able to launch GUI without any error 

Additional info:

Comment 2 Shwetha Kallesh 2017-11-10 11:00:40 UTC
GUI also doesnot launch when there are any corrupt product certs

[shwetha@dhcp35-121 ~]$ subscription-manager-gui
Error loading certificate: /etc/pki/product-default/69.pem

Comment 3 Chris Snyder 2017-11-16 15:28:51 UTC

*** This bug has been marked as a duplicate of bug 1510727 ***


Note You need to log in before you can comment on or make changes to this bug.