Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511760 - [DOCS] mediawiki rollout fail while usr change db serviceinstance
Summary: [DOCS] mediawiki rollout fail while usr change db serviceinstance
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.0
Assignee: Brandi
QA Contact: Zihan Tang
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 03:56 UTC by Zhang Cheng
Modified: 2018-05-09 00:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-27 21:18:28 UTC


Attachments (Terms of Use)

Comment 1 Zhang Cheng 2017-11-10 03:58:06 UTC
I don't think it is a block issue for ocp3.7 GA. You can change target to 3.8 if you think so.

Comment 3 Michael Hrivnak 2018-01-03 21:16:58 UTC
I am able to reproduce this. When running step 7, the automatic re-deploy of mediawiki fails with this error: "Error: secrets "dh-postgresql-apb-h2gql-credentials-i5r30" not found"

It seems that when a secret gets deleted, something needs to remove it from a DeploymentConfig it had previously been added to. I'm not sure who/what should be responsible for that.

Right now, there's a big "Add to Application" button in the UI for a secret that adds it to a DeploymentConfig. Perhaps that's a starting point for thinking about the lifecycle of a secret's relationship to a binding.

Comment 4 David Zager 2018-01-15 20:32:16 UTC
@John After our discussion https://www.redhat.com/archives/ansible-service-broker/2018-January/msg00000.html we determined that this most likely belongs to the web console folks. As there already exists a method to "Add to Application", a "Remove from Application" (or similar) should also exist to remove the secret from the deploymentconfig.

Comment 5 Samuel Padgett 2018-01-17 01:21:35 UTC
This is working as intended. Your deployment references a secret that no longer exists, which *should* block the rollout.

It is up to the user to remove the secret from the deployment environment tab. Since adding the secret is a manual step, I don't think it's unreasonable to ask the user to remove the secret. You should see a warning on the deployment page if your deployment references a missing secret as well as an event in the notification drawer (the bell icon in the masthead). As a developer, I'd want the rollout to fail to tell me something is wrong and the secret won't be added.

A "Remove from Application" button won't work here since the secret is deleted and there is no longer a page to add the button to, but it's still possible to remove the secret from the deployment.

Comment 6 Michael Hrivnak 2018-01-17 03:24:15 UTC
Thank you Sam for the explanation, based on which I'm closing this as "not a bug". I'm also changing the component to "management console" in case there are any follow-up questions.

Comment 7 Zhang Cheng 2018-01-17 05:38:35 UTC
Micheal & Samuel,

I think that is OKay base on your explanation. Should we highlight these info in user guide(or some docs)? We can continue to use this bug for tracing or open another one if need.

Thanks.

Comment 8 Zhang Cheng 2018-01-17 05:42:11 UTC
I'm re-opening this bug, only for make sure everything can be traced well. You can close it if don't think it no longer need to trace. Thanks.

Comment 9 Samuel Padgett 2018-01-17 11:02:14 UTC
We could add a comment about this to

https://docs.openshift.org/latest/architecture/service_catalog/index.html#service-catalog-deleting-resources

Comment 10 Jessica Forrester 2018-01-17 16:02:28 UTC
moving to the docs component to track

Comment 12 Brandi 2018-03-22 20:17:47 UTC
Docs PR: https://github.com/openshift/openshift-docs/pull/8372

Comment 13 Zihan Tang 2018-03-23 07:13:43 UTC
@Vikram , since this issue still exist in v3.7,  is this pr will also be merged in v3.7

Comment 14 Zihan Tang 2018-03-23 07:32:13 UTC
@Brandi,
'you must also remove the secret from the deployment environment tab' 
it's better to figure out that the secret reference should be removed from deployment config , and currently we can not remove it from UI.
thanks.

Comment 15 Brandi 2018-03-23 18:43:05 UTC
Thank you for the clarification. The wording on the PR has been updated. Please take another look. We can update 3.7 as well. Thanks again!

Comment 16 Zihan Tang 2018-03-26 03:08:20 UTC
the update LGTM.
@Brandi, about 3.7 update, will you open another PR or open another bug to trace it ?

Comment 17 Brandi 2018-03-26 15:26:25 UTC
Thanks, Zihan! I will cherrypick to 3.7 and 3.9 from PR8372, so no need for a second bug.

Comment 18 Zihan Tang 2018-03-27 05:53:25 UTC
Verified based on comment 16 & comment 17


Note You need to log in before you can comment on or make changes to this bug.