Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1511756 - Failed to detects OS version for rhel7.4
Summary: Failed to detects OS version for rhel7.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo
Version: 7.5
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Felipe Borges
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 03:23 UTC by zhoujunqin
Modified: 2018-04-10 16:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 16:39:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0917 None None None 2018-04-10 16:40:11 UTC

Description zhoujunqin 2017-11-10 03:23:36 UTC
Description of problem:
Failed to detects OS version for rhel7.4 

Version-Release number of selected component (if applicable):
virt-install-1.4.3-1.el7.noarch
libosinfo-1.0.0-1.el7.x86_64
osinfo-db-20170813-2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.
# osinfo-query os 

** (osinfo-query:24275): WARNING **: Entity http://redhat.com/rhl/7.4 referenced but not defined
 Short ID             | Name                                               | Version  | ID                                      
----------------------+----------------------------------------------------+----------+-----------------------------------------
...

 rhel7.4              | Red Hat Enterprise Linux 7.4                       | 7.4      | http://redhat.com/rhel/7.4              
 rhel7.4              | Red Hat Enterprise Linux 7.5                       | 7.5      | http://redhat.com/rhel/7.5       

Actual results:
As above, detects rhel7.4 version as rhel7.5 when i install a rhel7.4 guest on virt-manager.

Expected results:
Fix it.

Additional info:

Comment 2 Christophe Fergeau 2017-11-10 10:06:19 UTC
The patches in the 7.4 and 7.5 branches add some "Red Hat Linux 7.x"/rhl entries which should not be there. Red Hat Linux was a thing *before* Red Hat Enterprise Linux was introduced, this does not exist anymore.

Comment 3 Xiaodai Wang 2017-11-10 10:23:56 UTC
The short ID of "Red Hat Enterprise Linux 7.5" is rhel7.4 instead of rhel7.5.

Comment 11 errata-xmlrpc 2018-04-10 16:39:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0917


Note You need to log in before you can comment on or make changes to this bug.